aboutsummaryrefslogtreecommitdiff
path: root/net/opal/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-02-05 13:39:41 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-02-05 13:39:41 +0000
commitb91fd53f32ad94577a37a5d3b15b8be9364b19c8 (patch)
tree00cae6ba9febbb13b10f4469fc28b9f64af3be36 /net/opal/Makefile
parentd1110499cf93f021999d9389ae13e67a6518cc42 (diff)
Notes
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile58
1 files changed, 13 insertions, 45 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 5dbdfe458cfa..e0500c9efd6b 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -6,61 +6,29 @@
#
PORTNAME= openh323
-PORTVERSION= 1.12.2
-PORTREVISION= 1
+PORTVERSION= 1.17.3
CATEGORIES= net
-MASTER_SITES= http://www.openh323.org/bin/ \
- http://www.de.openh323.org/bin/ \
- http://www.gnomemeeting.org/downloads/0.98.0/sources/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= http://www.voxgratia.org/releases/
+DISTFILES= openh323-v1_17_3-src-tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ pt_FreeBSD_x86_r.1:${PORTSDIR}/devel/pwlib
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-# Check for telephony.h in the two places the source is hard coded to check
-# /usr/include/sys and /usr/local/include/sys
-# If it is not present, extract it from the comms/ixj port
-.if !exists(/usr/include/sys/telephony.h)
-.if !exists(/usr/local/include/sys/telephony.h)
-PATCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
-.endif
-.endif
-.endif
+WRKSRC= ${WRKDIR}/openh323_v1_17_3
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-PLIST_FILES= bin/simph323
USE_BISON= yes
-
USE_GMAKE= yes
USE_OPENLDAP= yes
-USE_AUTOTOOLS= autoconf:259 autoconf:253:env
+USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
-PWLIBDIR!= cd ${PORTSDIR}/devel/pwlib && make -V WRKSRC
-CONFIGURE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
-ALL_TARGET= optnoshared
-MAKE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
-THE_MACHTYPE= ${ARCH:S/i386/x86/}
-MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
-
-post-patch:
-.if ${OSVERSION} < 500000
-.if !exists(/usr/include/sys/telephony.h)
-.if !exists(/usr/local/include/sys/telephony.h)
- # Copy ixj driver include files into OpenH323 include directory
- ${MKDIR} ${WRKDIR}/openh323/include/sys
- ${CP} ${WRKDIRPREFIX}${.CURDIR}/../../comms/ixj/work/ixj_freebsd/telephony.h ${WRKDIR}/openh323/include/sys
- ${CP} ${WRKDIRPREFIX}${.CURDIR}/../../comms/ixj/work/ixj_freebsd/ixjuser.h ${WRKDIR}/openh323/include/sys
-.endif
-.endif
-.endif
+INSTALLS_SHLIB= yes
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
+NO_FILTER_SHLIBS= yes
+ALL_TARGET= optshared
+MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>