aboutsummaryrefslogtreecommitdiff
path: root/net/opal3
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2009-10-20 06:26:32 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2009-10-20 06:26:32 +0000
commit44fd2e0625352f17181f1bc7f664c35e3f97c02b (patch)
tree688aecb870142347cdeece0db0f7957f2a34bae1 /net/opal3
parent15b12f2a284dee163f6502766e241e5afec00308 (diff)
Notes
Diffstat (limited to 'net/opal3')
-rw-r--r--net/opal3/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index aa51b81c16fe..e94c4bbedfef 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opal3
PORTVERSION= 3.6.6
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/opalvoip/v3.6%20Lalande/Stable%205
DISTNAME= opal-${PORTVERSION}
@@ -29,7 +30,7 @@ CXXFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-OPTIONS= ZRTP "Enable ZRTP protocol support" on \
+OPTIONS= ZRTP "Enable ZRTP protocol support" off \
JAVA "Enable Java JNI support" off \
CELT "Use celt codec from ports" on \
ILBC "USE iLBC codec from ports" off \
@@ -66,6 +67,9 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} \
PVERSION_MINOR=${PORTVERSION:C/^[0-9]+.[0-9]+.//}
.if defined(WITH_ZRTP)
+.if !defined(SAFE_ZRTP)
+IGNORE= Please build devel/libzrtpcpp WITHOUT ports SSL and re-run build with SAFE_ZRTP set
+.endif
LIB_DEPENDS+= zrtpcpp.0:${PORTSDIR}/devel/libzrtpcpp
CONFIGURE_ARGS+= --enable-zrtp
.else