aboutsummaryrefslogtreecommitdiff
path: root/net/opal
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-05 02:44:55 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-05 02:44:55 +0000
commit5e3c765f2d1ca65922723433f6ef10b76cb08cf9 (patch)
tree43eb1080665ef3256255f591e285c2f70f7b2fd5 /net/opal
parentdfe986b9e78378c33f917807138dd46b088ac3fe (diff)
downloadports-5e3c765f2d1ca65922723433f6ef10b76cb08cf9.tar.gz
ports-5e3c765f2d1ca65922723433f6ef10b76cb08cf9.zip
Notes
Diffstat (limited to 'net/opal')
-rw-r--r--net/opal/Makefile10
-rw-r--r--net/opal/distinfo6
-rw-r--r--net/opal/files/patch-Makefile.in10
-rw-r--r--net/opal/files/patch-libspeex6
-rw-r--r--net/opal/pkg-plist2
5 files changed, 17 insertions, 17 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 8a691c50ee98..bd674cebb606 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= opal
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= net
MASTER_SITES= http://www.voxgratia.org/releases/
DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
@@ -18,7 +17,7 @@ COMMENT= VoIP abstraction library
LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
-WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
+WRKSRC= ${WRKDIR}/${PORTNAME}_Phobos_release2
# In opal's Makefile the default make's target is optshared
ALL_TARGET= optshared
@@ -30,6 +29,7 @@ NO_FILTER_SHLIBS= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
@@ -37,8 +37,8 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include
BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
.endif
-# Avoid build error on amd64: relocation R_X86_64_32 can not be used when making a shared object; recompile with -fPIC
-.if (${ARCH} == "amd64")
+# Avoid build error on 64-bit architectures
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
.endif
diff --git a/net/opal/distinfo b/net/opal/distinfo
index 6b743bb33c55..6f2205b6aad2 100644
--- a/net/opal/distinfo
+++ b/net/opal/distinfo
@@ -1,3 +1,3 @@
-MD5 (opal-v2_2_1-src-tar.gz) = a98f5e3b975215a2059582095d5c22d0
-SHA256 (opal-v2_2_1-src-tar.gz) = 4c35efa7cc3b8315cf4639629615de80f7aee709c5caf60064f92274e229eead
-SIZE (opal-v2_2_1-src-tar.gz) = 4091526
+MD5 (opal-v2_2_2-src-tar.gz) = 71e42bcfeaec6dd830c88f7482fe9d41
+SHA256 (opal-v2_2_2-src-tar.gz) = 49215c952a82ffda859785f1259c557880ac9889ad2a4c7a554f9525ccdb9a7c
+SIZE (opal-v2_2_2-src-tar.gz) = 4096984
diff --git a/net/opal/files/patch-Makefile.in b/net/opal/files/patch-Makefile.in
index 155a5b377824..43ac050eaf72 100644
--- a/net/opal/files/patch-Makefile.in
+++ b/net/opal/files/patch-Makefile.in
@@ -1,13 +1,13 @@
---- Makefile.in.orig Tue Apr 11 14:19:57 2006
-+++ Makefile.in Tue Apr 11 14:20:39 2006
-@@ -419,10 +419,6 @@
+--- Makefile.in.orig Sat Apr 22 16:06:54 2006
++++ Makefile.in Thu Jun 22 09:39:04 2006
+@@ -427,10 +427,6 @@
SOURCES += $(OPAL_SRCDIR)/lids/vpblid.cxx
endif
-
+
-ifdef HAS_SANGOMA
-SOURCES += $(OPAL_SRCDIR)/lids/sangomalid.cxx
-endif
-
-
+
##################
# Software codecs
diff --git a/net/opal/files/patch-libspeex b/net/opal/files/patch-libspeex
index 995ce4236118..5e452da8fc77 100644
--- a/net/opal/files/patch-libspeex
+++ b/net/opal/files/patch-libspeex
@@ -1,10 +1,10 @@
---- src/codec/speex/libspeex/kiss_fft.h.orig Tue Apr 4 10:58:34 2006
-+++ src/codec/speex/libspeex/kiss_fft.h Tue Apr 4 10:58:57 2006
+--- src/codec/speex/libspeex/kiss_fft.h.orig Thu Jun 22 09:56:34 2006
++++ src/codec/speex/libspeex/kiss_fft.h Thu Jun 22 09:56:53 2006
@@ -6,10 +6,6 @@
#include <math.h>
#include <memory.h>
--#ifndef P_MACOSX
+-#if !(defined(P_MACOSX) || defined(P_FREEBSD))
-#include <malloc.h> // RMF
-#endif
-
diff --git a/net/opal/pkg-plist b/net/opal/pkg-plist
index 9da7083ae6e4..4729f1f5f826 100644
--- a/net/opal/pkg-plist
+++ b/net/opal/pkg-plist
@@ -111,7 +111,7 @@ lib/libopal.so
lib/libopal_r.so
lib/libopal_r.so.2
lib/libopal_r.so.2.2
-lib/libopal_r.so.2.2.1
+lib/libopal_r.so.%%PORTVERSION%%
share/opal/opal_inc.mak
@dirrm share/opal
@dirrm include/opal/t38