aboutsummaryrefslogtreecommitdiff
path: root/net/openbgpd/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-06-03 20:08:36 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-06-03 20:08:36 +0000
commit713c2289b8d66d3752c1225ca18d740daa50c8fc (patch)
tree26af7b6de4c410d2e2810fec4c81c3ab0b9c5e76 /net/openbgpd/Makefile
parent21a86ae3bec8cae0c6d43e2aac91722eca58186e (diff)
downloadports-713c2289b8d66d3752c1225ca18d740daa50c8fc.tar.gz
ports-713c2289b8d66d3752c1225ca18d740daa50c8fc.zip
Notes
Diffstat (limited to 'net/openbgpd/Makefile')
-rw-r--r--net/openbgpd/Makefile30
1 files changed, 20 insertions, 10 deletions
diff --git a/net/openbgpd/Makefile b/net/openbgpd/Makefile
index 346d4be10e53..3262c1935d70 100644
--- a/net/openbgpd/Makefile
+++ b/net/openbgpd/Makefile
@@ -1,9 +1,13 @@
# $FreeBSD$
PORTNAME= openbgpd
-PORTVERSION= 6.5p0
+PORTVERSION= 5.2.20121209
+PORTREVISION= 3
+PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= OPENBSD/OpenBGPD
+DISTNAME= ${PORTNAME}-4.6
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Free implementation of the Border Gateway Protocol, Version 4
@@ -11,21 +15,27 @@ COMMENT= Free implementation of the Border Gateway Protocol, Version 4
LICENSE= ISCL
LICENSE_FILE= ${FILESDIR}/COPYING
-USES= autoreconf libtool uidfix
-USE_RC_SUBR= ${PORTNAME}
+CONFLICTS= zebra-[0-9]* quagga-[0-9]*
-GNU_CONFIGURE= yes
+USES= tar:tgz uidfix
+USE_RC_SUBR= ${PORTNAME}
+NO_WRKSUBDIR= yes
+PLIST_FILES= sbin/bgpctl sbin/bgpd man/man5/bgpd.conf.5.gz \
+ man/man8/bgpctl.8.gz man/man8/bgpd.8.gz
SUB_FILES= pkg-message
-
USERS= _bgpd
GROUPS= _bgpd
-CONFLICTS= zebra-[0-9]* quagga-[0-9]*
-
-OPTIONS_DEFINE= IPV6LLPEER
-OPTIONS_DEFAULT= IPV6LLPEER
-IPV6LLPEER_DESC= Support nexthop using IPv6 link-local address
+OPTIONS_DEFINE= IPV6LLPEER
+OPTIONS_DEFAULT=IPV6LLPEER
+IPV6LLPEER_DESC=Support nexthop using IPv6 link-local address
IPV6LLPEER_MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/bgpd/bgpd.8 \
+ ${WRKSRC}/bgpd/bgpd.conf.5 \
+ ${WRKSRC}/bgpctl/bgpctl.8
+
.include <bsd.port.mk>