aboutsummaryrefslogtreecommitdiff
path: root/net/openbgpd/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-05-31 15:04:30 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-05-31 15:04:30 +0000
commite3e5543a6dc3364105a52ea6b86c3f060bd230e2 (patch)
tree41240bb6a84aa0d4143fc4a8d939e719a4f83e79 /net/openbgpd/Makefile
parent75b69fed682eeb918b8cb5661e89976ee7328f25 (diff)
downloadports-e3e5543a6dc3364105a52ea6b86c3f060bd230e2.tar.gz
ports-e3e5543a6dc3364105a52ea6b86c3f060bd230e2.zip
Notes
Diffstat (limited to 'net/openbgpd/Makefile')
-rw-r--r--net/openbgpd/Makefile29
1 files changed, 10 insertions, 19 deletions
diff --git a/net/openbgpd/Makefile b/net/openbgpd/Makefile
index 7de2994c9309..346d4be10e53 100644
--- a/net/openbgpd/Makefile
+++ b/net/openbgpd/Makefile
@@ -1,12 +1,9 @@
# $FreeBSD$
PORTNAME= openbgpd
-PORTVERSION= 5.2.20121209
-PORTREVISION= 3
+PORTVERSION= 6.5p0
CATEGORIES= net
MASTER_SITES= OPENBSD/OpenBGPD
-DISTNAME= ${PORTNAME}-4.6
-DIST_SUBDIR= ${PORTNAME}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Free implementation of the Border Gateway Protocol, Version 4
@@ -14,27 +11,21 @@ COMMENT= Free implementation of the Border Gateway Protocol, Version 4
LICENSE= ISCL
LICENSE_FILE= ${FILESDIR}/COPYING
-CONFLICTS= zebra-[0-9]* quagga-[0-9]*
-
-USES= tar:tgz uidfix
+USES= autoreconf libtool uidfix
USE_RC_SUBR= ${PORTNAME}
-NO_WRKSUBDIR= yes
-PLIST_FILES= sbin/bgpctl sbin/bgpd man/man5/bgpd.conf.5.gz \
- man/man8/bgpctl.8.gz man/man8/bgpd.8.gz
+GNU_CONFIGURE= yes
+
SUB_FILES= pkg-message
+
USERS= _bgpd
GROUPS= _bgpd
-OPTIONS_DEFINE= IPV6LLPEER
-OPTIONS_DEFAULT=IPV6LLPEER
-IPV6LLPEER_DESC=Support nexthop using IPv6 link-local address
-IPV6LLPEER_MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
+CONFLICTS= zebra-[0-9]* quagga-[0-9]*
-post-patch:
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
- ${WRKSRC}/bgpd/bgpd.8 \
- ${WRKSRC}/bgpd/bgpd.conf.5 \
- ${WRKSRC}/bgpctl/bgpctl.8
+OPTIONS_DEFINE= IPV6LLPEER
+OPTIONS_DEFAULT= IPV6LLPEER
+IPV6LLPEER_DESC= Support nexthop using IPv6 link-local address
+IPV6LLPEER_MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
.include <bsd.port.mk>