aboutsummaryrefslogtreecommitdiff
path: root/net/openh323-112/Makefile
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2002-01-15 15:06:17 +0000
committerRoger Hardiman <roger@FreeBSD.org>2002-01-15 15:06:17 +0000
commit87de83a55d8095c2179a98f6c91f7b14a5b6477d (patch)
treef694d96d823db1c46535859dd1b53f352d141945 /net/openh323-112/Makefile
parent20d295dead62b5c1653984fcf46014fa0027f20e (diff)
downloadports-87de83a55d8095c2179a98f6c91f7b14a5b6477d.tar.gz
ports-87de83a55d8095c2179a98f6c91f7b14a5b6477d.zip
Notes
Diffstat (limited to 'net/openh323-112/Makefile')
-rw-r--r--net/openh323-112/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/net/openh323-112/Makefile b/net/openh323-112/Makefile
index bebd1444e269..58e4a9cfb7e9 100644
--- a/net/openh323-112/Makefile
+++ b/net/openh323-112/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.7.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,6 +17,12 @@ DISTFILES= openh323_1.7.4.tar.gz \
MAINTAINER= roger@freebsd.org
+# Check for telephony.h in /usr/include/sys and in $PREFIX/include/sys.
+# If it is not present, extract it from the comms/ixj port
+.if !exists(/usr/include/sys/telephony.h)
+BUILD_DEPENDS= ${PREFIX}/include/sys/telephony.h:${PORTSDIR}/comms/ixj:patch
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_NEWGCC= yes
@@ -29,6 +35,16 @@ MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+post-patch:
+.if !exists(/usr/include/sys/telephony.h)
+.if !exists($(PREFIX)/sys/telephony.h)
+ # Copy over ixj driver include files into OpenH323 include directory
+ ${MKDIR} ${WRKDIR}/openh323/include/sys
+ ${CP} ${PORTSDIR}/comms/ixj/work/ixj_freebsd/telephony.h ${WRKDIR}/openh323/include/sys
+ ${CP} ${PORTSDIR}/comms/ixj/work/ixj_freebsd/ixjuser.h ${WRKDIR}/openh323/include/sys
+.endif
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin