aboutsummaryrefslogtreecommitdiff
path: root/net/openh323proxy
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2000-11-22 17:51:42 +0000
committerRoger Hardiman <roger@FreeBSD.org>2000-11-22 17:51:42 +0000
commitdae7c4389dce76c6adc70913329bf59b5d626abb (patch)
tree77d484e90b1bd03f9786c86d74fa0389d6a88cdb /net/openh323proxy
parent353027ba43fe01deeb88323533c15847dee09788 (diff)
downloadports-dae7c4389dce76c6adc70913329bf59b5d626abb.tar.gz
ports-dae7c4389dce76c6adc70913329bf59b5d626abb.zip
Notes
Diffstat (limited to 'net/openh323proxy')
-rw-r--r--net/openh323proxy/Makefile34
-rw-r--r--net/openh323proxy/distinfo1
-rw-r--r--net/openh323proxy/files/patch-aa19
-rw-r--r--net/openh323proxy/files/patch-ab38
-rw-r--r--net/openh323proxy/files/patch-ac30
-rw-r--r--net/openh323proxy/pkg-comment1
-rw-r--r--net/openh323proxy/pkg-descr15
-rw-r--r--net/openh323proxy/pkg-plist1
8 files changed, 139 insertions, 0 deletions
diff --git a/net/openh323proxy/Makefile b/net/openh323proxy/Makefile
new file mode 100644
index 000000000000..3f7551a9c80a
--- /dev/null
+++ b/net/openh323proxy/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: openh323proxy
+# Date created: Tue Nov 21 12:59:00 GMT 2000
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openh323proxy
+PORTVERSION= 0.9a3.m08
+CATEGORIES= net
+MASTER_SITES= http://download.sourceforge.net/openh323proxy/
+DISTNAME= ${PORTNAME}_0.9a3_m08
+
+MAINTAINER= roger@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NOCLEANDEPENDS= yes
+
+USE_NEWGCC= yes
+USE_BISON= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/opengate_proxy ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/openh323proxy/distinfo b/net/openh323proxy/distinfo
new file mode 100644
index 000000000000..caa0206c7602
--- /dev/null
+++ b/net/openh323proxy/distinfo
@@ -0,0 +1 @@
+MD5 (openh323proxy_0.9a3_m08.tar.gz) = 6a94049a8cf965e41e15a382cf1b93a2
diff --git a/net/openh323proxy/files/patch-aa b/net/openh323proxy/files/patch-aa
new file mode 100644
index 000000000000..755a523ccc86
--- /dev/null
+++ b/net/openh323proxy/files/patch-aa
@@ -0,0 +1,19 @@
+*** Makefile.orig Wed Nov 22 14:00:59 2000
+--- Makefile Wed Nov 22 14:00:02 2000
+***************
+*** 70,76 ****
+ #
+
+
+! PROG = opengate
+ SOURCES = opengate.cxx EndpointTabl.cxx RasThread.cxx RasServer.cxx MulticastThread.cxx \
+ AddrUtils.cxx Log.cxx CallTabl.cxx CallThread.cxx Environ.cxx DNSUtils.cxx \
+ Proxy.cxx ProxyTabl.cxx ProxyThread.cxx ProxyCriteria.cxx
+--- 70,76 ----
+ #
+
+
+! PROG = opengate_proxy
+ SOURCES = opengate.cxx EndpointTabl.cxx RasThread.cxx RasServer.cxx MulticastThread.cxx \
+ AddrUtils.cxx Log.cxx CallTabl.cxx CallThread.cxx Environ.cxx DNSUtils.cxx \
+ Proxy.cxx ProxyTabl.cxx ProxyThread.cxx ProxyCriteria.cxx
diff --git a/net/openh323proxy/files/patch-ab b/net/openh323proxy/files/patch-ab
new file mode 100644
index 000000000000..55376d2e5ae7
--- /dev/null
+++ b/net/openh323proxy/files/patch-ab
@@ -0,0 +1,38 @@
+*** opengate.cxx.orig Thu Oct 26 13:05:21 2000
+--- opengate.cxx Wed Nov 22 13:59:34 2000
+*************** static PSemaphore TerminatedSema(0,1);
+*** 101,107 ****
+ PCREATE_PROCESS(opengate)
+
+ opengate::opengate()
+! : PServiceProcess("Egoboo", "opengate",
+ GKVER_MAJOR, GKVER_MINOR, GKVER_STATUS, GKVER_BUILD
+ )
+ {
+--- 101,107 ----
+ PCREATE_PROCESS(opengate)
+
+ opengate::opengate()
+! : PServiceProcess("Marco Polci and Egoboo", "openh323proxy",
+ GKVER_MAJOR, GKVER_MINOR, GKVER_STATUS, GKVER_BUILD
+ )
+ {
+*************** void opengate::Main()
+*** 165,172 ****
+ PString AkaLocalAddr = Cfg.GetString( "Local Address", "*" );
+ MyEnviron.LocalAddr = AkaLocalAddr;
+
+! // Set the gatekeeper id, the default is "Opengate: " + hostname
+! PString AkaMyId = Cfg.GetString( "Gatekeeper Id", (PString) "Opengate: " + PIPSocket::GetHostName() );
+ MyEnviron.MyId = AkaMyId;
+ // if ( MyEnviron.LocalAddr == INADDR_ANY )
+ // PIPSocket::GetHostAddress( MyEnviron.LocalAddr );
+--- 165,172 ----
+ PString AkaLocalAddr = Cfg.GetString( "Local Address", "*" );
+ MyEnviron.LocalAddr = AkaLocalAddr;
+
+! // Set the gatekeeper id, the default is "OpengateProxy: " + hostname
+! PString AkaMyId = Cfg.GetString( "Gatekeeper Id", (PString) "OpengateProxy: " + PIPSocket::GetHostName() );
+ MyEnviron.MyId = AkaMyId;
+ // if ( MyEnviron.LocalAddr == INADDR_ANY )
+ // PIPSocket::GetHostAddress( MyEnviron.LocalAddr );
diff --git a/net/openh323proxy/files/patch-ac b/net/openh323proxy/files/patch-ac
new file mode 100644
index 000000000000..4c29fe697628
--- /dev/null
+++ b/net/openh323proxy/files/patch-ac
@@ -0,0 +1,30 @@
+*** Log.cxx.orig Mon Oct 16 14:39:43 2000
+--- Log.cxx Wed Nov 22 13:59:51 2000
+*************** OpengateLog::OpengateLog() : Cfg("Log")
+*** 66,72 ****
+ PTime now;
+ PString DateStamp = now.AsString("hh:mm:ss dd/MM/yyyy");
+ PString StartupMsg = "Starting logging: ";
+! LogFilename = Cfg.GetString("File", "OpengateLog.txt");
+
+ // Check to see if logging has been requested
+ // If none then do not open log file
+--- 66,72 ----
+ PTime now;
+ PString DateStamp = now.AsString("hh:mm:ss dd/MM/yyyy");
+ PString StartupMsg = "Starting logging: ";
+! LogFilename = Cfg.GetString("File", "opengate_proxy.log");
+
+ // Check to see if logging has been requested
+ // If none then do not open log file
+*************** void OpengateLog::LogH245Msg(const H245_
+*** 268,271 ****
+ }
+ WriteTrailer();
+ }
+! }
+--- 268,271 ----
+ }
+ WriteTrailer();
+ }
+! }
diff --git a/net/openh323proxy/pkg-comment b/net/openh323proxy/pkg-comment
new file mode 100644
index 000000000000..af5d9f1b2cf3
--- /dev/null
+++ b/net/openh323proxy/pkg-comment
@@ -0,0 +1 @@
+Proxy for Videoconferencing and VoIP using H323 (eg OhPhone and NetMeeting)
diff --git a/net/openh323proxy/pkg-descr b/net/openh323proxy/pkg-descr
new file mode 100644
index 000000000000..65b379bdfd54
--- /dev/null
+++ b/net/openh323proxy/pkg-descr
@@ -0,0 +1,15 @@
+OpenH323Proxy is a Gatekeeper and Proxy for Video Conferencing and
+Internet Phone (VoIP) applications using the H323 protocol.
+
+The H323 protocol is used by OpenH323, OhPhone and Microsoft's NetMeeting
+plus many other applications.
+
+It makes use of PWLib and the OpenH323 stack from Equivalence Ltd Pty
+and as it is based on OpenGatekeeper from Egoboo, it is a
+gatekeeper as well as a proxy.
+
+WWW: http://openh323proxy.sourceforge.net/
+
+and
+
+WWW: http://www.openh323.org/
diff --git a/net/openh323proxy/pkg-plist b/net/openh323proxy/pkg-plist
new file mode 100644
index 000000000000..078b9b6b1222
--- /dev/null
+++ b/net/openh323proxy/pkg-plist
@@ -0,0 +1 @@
+bin/opengate_proxy