aboutsummaryrefslogtreecommitdiff
path: root/net/openldap/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-02 03:27:54 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-02 03:27:54 +0000
commit57298ea74813e4038ae96cd2196affe69181f9fc (patch)
treeedb4544b269129068fc8927705aaaa1c11d76f9a /net/openldap/Makefile
parent30fe50276dc1a3d4ba4a4ee7d6755e78579df3ce (diff)
downloadports-57298ea74813e4038ae96cd2196affe69181f9fc.tar.gz
ports-57298ea74813e4038ae96cd2196affe69181f9fc.zip
Notes
Diffstat (limited to 'net/openldap/Makefile')
-rw-r--r--net/openldap/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/openldap/Makefile b/net/openldap/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap/Makefile
+++ b/net/openldap/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"