aboutsummaryrefslogtreecommitdiff
path: root/net/openldap21-server
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-03-25 01:46:54 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-03-25 01:46:54 +0000
commit219b30185a9edf352eb05e908208f4ef3f8d82a9 (patch)
tree5cc43b73efa79988b1c493c377291aa44e93d27f /net/openldap21-server
parent972cb30fb7d3b2f696db2f7c450b8d1db702567c (diff)
downloadports-219b30185a9edf352eb05e908208f4ef3f8d82a9.tar.gz
ports-219b30185a9edf352eb05e908208f4ef3f8d82a9.zip
Notes
Diffstat (limited to 'net/openldap21-server')
-rw-r--r--net/openldap21-server/Makefile6
-rw-r--r--net/openldap21-server/files/patch-build::ltmain.sh33
2 files changed, 35 insertions, 4 deletions
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index ccab5660c961..44981acd628d 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -62,7 +62,7 @@ CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[02-9].*
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -245,12 +245,10 @@ post-patch:
${WRKSRC}/servers/slapd/slapd.conf
pre-configure:
- @if [ -n "`${PKG_INFO} -xI '^bind\(84\)\{0,1\}-base-8\.'`" ]; then \
+ @if [ -n "`${PKG_INFO} -xI '^bind\(84\)\{0,1\}-base-8\.' 2>/dev/null`" ]; then \
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
- ${WRKSRC}/configure
post-build:
.for script in slapd slurpd
diff --git a/net/openldap21-server/files/patch-build::ltmain.sh b/net/openldap21-server/files/patch-build::ltmain.sh
new file mode 100644
index 000000000000..53bc16473d95
--- /dev/null
+++ b/net/openldap21-server/files/patch-build::ltmain.sh
@@ -0,0 +1,33 @@
+--- build/ltmain.sh.orig Mon Feb 10 20:24:24 2003
++++ build/ltmain.sh Thu Mar 25 02:17:45 2004
+@@ -1066,7 +1066,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -4286,10 +4286,17 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
+- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+- instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
++ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
++ instname="$dir/$name"i
++ $show "$install_prog $instname $destdir/$name"
++ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ ;;
++ esac
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"