aboutsummaryrefslogtreecommitdiff
path: root/net/openldap22-server/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-10-31 11:42:22 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-10-31 11:42:22 +0000
commitab4bc8e81ebed5f18635f2c0e12ca22ee2792425 (patch)
tree6e3f16c1056b88dd7f0017acdccc130d89ad5b6e /net/openldap22-server/Makefile
parentef24f19ee87c0a94a3074c3a5b31afca7249b65c (diff)
Add openldap2 (OpenLDAP 2.0.6) after a repocopy from net/openldap
(OpenLDAP 1.2.x).
Notes
Notes: svn path=/head/; revision=34489
Diffstat (limited to 'net/openldap22-server/Makefile')
-rw-r--r--net/openldap22-server/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 5cdce9acb1a8..77b2df0e6ac2 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: OpenLDAP 1.x
+# New ports collection makefile for: OpenLDAP 2.x
# Date created: 20 Sep 1998
# Whom: Lachlan O'Dea
#
@@ -6,8 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.11
-PORTREVISION= 1
+PORTVERSION= 2.0.6
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.net.lut.ac.uk/openldap/%SUBDIR%/ \
@@ -21,13 +20,16 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
MASTER_SITE_SUBDIR= openldap-release
EXTRACT_SUFX= .tgz
-MAINTAINER= lodea@vet.com.au
+MAINTAINER= knu@FreeBSD.org
+USE_AUTOCONF= yes
USE_LIBTOOL= yes
+USE_OPENSSL= yes
CONFIGURE_ARGS= --localstatedir=/var/run \
--enable-shared \
- --enable-dns
+ --enable-dnssrv \
+ --with-tls=openssl
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
@@ -58,19 +60,14 @@ BINS= bin/ldapadd \
libexec/rcpt500 \
libexec/rp500 \
libexec/slapd \
- libexec/slurpd \
- sbin/centipede \
- sbin/ldbmcat \
- sbin/ldbmtest \
- sbin/ldif \
- sbin/ldif2id2children \
- sbin/ldif2id2entry \
- sbin/ldif2index \
- sbin/ldif2ldbm
+ libexec/slurpd
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
+post-configure:
+ cd ${WRKSRC} ; ${PATCH} < ${FILESDIR}/libtool.diff
+
pre-build:
cd ${WRKSRC} ; ${MAKE} depend