aboutsummaryrefslogtreecommitdiff
path: root/net/openldap23-server
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-05-26 15:11:35 +0000
committerXin LI <delphij@FreeBSD.org>2006-05-26 15:11:35 +0000
commitedcbb6b1bd5ab2a0654b1cf6273649146537bf68 (patch)
tree7ebbb6ae2564aeeb47a57506b4cf41e13c542a28 /net/openldap23-server
parent8116bf7c1f41c2725bd7d68589d44f15bfaad808 (diff)
According to the openldap configure script, by disabling
threading support the slurpd daemon would not be built. - New option: SLURPD to determine whether to build the replication daemon. (enabled by default). The replication functionality is not used by every user so it is desirable to give decision to the user. - When threading is disabled, reflect the fact that slurpd is not being built/installed. [1] This would also override the user chosen SLURPD option. - Disable SHELL backend by default. [1] Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=163490
Diffstat (limited to 'net/openldap23-server')
-rw-r--r--net/openldap23-server/Makefile24
-rw-r--r--net/openldap23-server/pkg-plist8
2 files changed, 21 insertions, 11 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 6215e4199582..57d643bcbfd1 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -40,12 +40,12 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 1
-PORTREVISION_SERVER= 0
+PORTREVISION_SERVER= 1
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" on \
PERL "With Perl backend" off \
- SHELL "With Shell backend (disables threading)" on \
+ SHELL "With Shell backend (disables threading)" off \
ODBC "With SQL backend" off \
SLP "With SLPv2 (RFC 2608) support" off \
SLAPI "With Netscape SLAPI plugin API" off \
@@ -67,7 +67,8 @@ OPTIONS= SASL "With (Cyrus) SASL2 support" on \
UNIQUE "With attribute Uniqueness overlay" off \
VALSORT "With Value Sorting overlay" off \
ACI "With per-object ACIs (experimental)" off \
- DYNAMIC_BACKENDS "Build dynamic backends" on
+ DYNAMIC_BACKENDS "Build dynamic backends" on \
+ SLURPD "Build slurpd replication daemon" on
.endif
.if defined(CLIENT_ONLY)
@@ -159,7 +160,7 @@ PKGMESSAGE= ${WRKSRC}/pkg-message.client
# server specific configuration
SUB_FILES+= pkg-deinstall pkg-message pkg-install
-USE_RC_SUBR= slapd.sh slurpd.sh
+USE_RC_SUBR= slapd.sh ${SLURPDSH}
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Makefile.in
@@ -295,11 +296,12 @@ CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDB_LIB_NAME:R},' \
-e 's,(ol_cv_lib_db=)yes$$,\1-l${BDB_LIB_NAME:R},'
.endif
-.if defined(WITHOUT_SHELL)
-PLIST_SUB+= BACK_SHELL="@comment "
-.else
+.if defined(WITH_SHELL)
CONFIGURE_ARGS+= --without-threads --enable-shell=${BACKEND_ENABLE}
PLIST_SUB+= BACK_SHELL=${BACKEND_PLIST}
+.else
+PLIST_SUB+= BACK_SHELL="@comment "
+WANT_OPENLDAP_THREADS= yes
.endif
.if defined(WITH_PERL)
@@ -343,6 +345,14 @@ CONFIGURE_ARGS+= --enable-slp
LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
.endif
+.if defined(WANT_OPENLDAP_THREADS) && !defined(WITHOUT_SLURPD)
+SLURPDSH= slurpd.sh
+PLIST_SUB+= SLURPD=""
+.else
+PLIST_SUB+= SLURPD="@comment "
+CONFIGURE_ARGS+= --disable-slurpd
+.endif
+
# Include tcp-wrapper support
.if !defined(WITHOUT_TCP_WRAPPERS) && exists(/usr/include/tcpd.h)
CONFIGURE_ARGS+= --enable-wrappers
diff --git a/net/openldap23-server/pkg-plist b/net/openldap23-server/pkg-plist
index 5c853821e62d..92dbca941187 100644
--- a/net/openldap23-server/pkg-plist
+++ b/net/openldap23-server/pkg-plist
@@ -1,6 +1,6 @@
@comment $FreeBSD$
@unexec %%RC_DIR%%/etc/rc.d/slapd%%RC_SUFX%% stop 2>&1 >/dev/null || true
-@unexec %%RC_DIR%%/etc/rc.d/slurpd%%RC_SUFX%% stop 2>&1 >/dev/null || true
+%%SLURPD%%@unexec %%RC_DIR%%/etc/rc.d/slurpd%%RC_SUFX%% stop 2>&1 >/dev/null || true
etc/openldap/schema/README
etc/openldap/schema/core.ldif
etc/openldap/schema/openldap.ldif
@@ -55,7 +55,7 @@ etc/openldap/DB_CONFIG.example
%%BACK_SQL%%libexec/openldap/back_sql.la
%%BACK_SQL%%libexec/openldap/back_sql.so
libexec/slapd
-libexec/slurpd
+%%SLURPD%%libexec/slurpd
@dirrmtry libexec/openldap
sbin/slapacl
sbin/slapadd
@@ -69,5 +69,5 @@ sbin/slaptest
@dirrmtry %%LDAP_RUN_DIR%%
@exec mkdir -p %%DATABASEDIR%%
@dirrmtry %%DATABASEDIR%%
-@exec mkdir -p %%SLURPDIR%%
-@dirrmtry %%SLURPDIR%%
+%%SLURPD%%@exec mkdir -p %%SLURPDIR%%
+%%SLURPD%%@dirrmtry %%SLURPDIR%%