aboutsummaryrefslogtreecommitdiff
path: root/net/openldap23-server
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2005-02-03 03:42:06 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2005-02-03 03:42:06 +0000
commitd6b4e48968eb7e8ee03d3df6b94db9e2a594bf65 (patch)
treeaa060c7c10680ffaf187f4aad0b6a4c7eba3e347 /net/openldap23-server
parentc1484c4f49c76f280668151242032c5950ea33bd (diff)
downloadports-d6b4e48968eb7e8ee03d3df6b94db9e2a594bf65.tar.gz
ports-d6b4e48968eb7e8ee03d3df6b94db9e2a594bf65.zip
Notes
Diffstat (limited to 'net/openldap23-server')
-rw-r--r--net/openldap23-server/Makefile28
-rw-r--r--net/openldap23-server/distinfo4
-rw-r--r--net/openldap23-server/files/patch-configure17
-rw-r--r--net/openldap23-server/files/patch-libraries::libldap::os-ip.c23
-rw-r--r--net/openldap23-server/files/patch-servers::slapd::back-ldap::search.c11
5 files changed, 62 insertions, 21 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 7c96b9236559..9fb728906ee4 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.19
+PORTVERSION= 2.2.23
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -126,6 +126,8 @@ CONFIGURE_ARGS+= --with-cyrus-sasl
CONFIGURE_ARGS+= --without-cyrus-sasl
.endif
+CONFIGURE_SED+= -e 's,(-lssl) +(-lcrypto),\2 \1,'
+
.if defined(CLIENT_ONLY)
# client specific configuration
@@ -150,9 +152,13 @@ PLIST_SUB+= MODULES=""
PLIST_SUB+= MODULES="@comment "
.endif
+SED_MODULES= -e 's/\(moduleload[ ]*back_[a-z]*\)\.la/\1/'
+
.if defined(WITH_DYNAMIC_BACKENDS)
BACKEND_ENABLE= "mod"
BACKEND_PLIST= ""
+SED_MODULES+= -e 's/\# *\(modulepath\)/\1/' \
+ -e 's/\# *\(moduleload[ ]*back_bdb\)/\1/'
.else
BACKEND_ENABLE= "yes"
BACKEND_PLIST= "@comment "
@@ -178,6 +184,10 @@ CONFIGURE_ARGS+= --enable-dyngroup
CONFIGURE_ARGS+= --enable-proxycache
.endif
+.if defined(WITH_ACI)
+CONFIGURE_ARGS+= --enable-aci
+.endif
+
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --disable-bdb \
--disable-hdb \
@@ -272,8 +282,9 @@ INSTALLS_SHLIB= yes
PLIST_SUB+= SLAPI="@comment "
.endif
-.if defined(WITH_CLDAP)
-CPPFLAGS+= -DLDAP_CONNECTIONLESS
+.if defined(WITH_SLP)
+CONFIGURE_ARGS+= --enable-slp
+LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
.endif
# Include tcp-wrapper support
@@ -284,6 +295,10 @@ CONFIGURE_ARGS+= --enable-wrappers
# end of client/server specific configuration
.endif
+.if defined(WITH_CLDAP)
+CPPFLAGS+= -DLDAP_CONNECTIONLESS
+.endif
+
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -328,11 +343,13 @@ pre-everything::
@${ECHO} "WITH_SHELL with Shell backend"
@${ECHO} "WITH_ODBC with SQL backend"
@${ECHO} "WITH_ODBC_TYPE select ODBC interface (iODBC or unixODBC)"
- @${ECHO} "WITH_SLAPI with Netscape SLAPI plugin API
+ @${ECHO} "WITH_SLP with SLPv2 (RFC 2608) support"
+ @${ECHO} "WITH_SLAPI with Netscape SLAPI plugin API"
@${ECHO} "WITHOUT_TCP_WRAPPERS without tcp wrapper support"
@${ECHO} "WITHOUT_BDB without BerkeleyDB support"
@${ECHO} "WITH_DYNGROUP with Dynamic Group overlay"
@${ECHO} "WITH_PROXYCACHE with Proxy Cache overlay"
+ @${ECHO} "WITH_ACI with per-object ACIs (experimental)"
@${ECHO} "WITH_DYNAMIC_BACKENDS build backends as modules"
.if defined(DFOSVERSION) || ${OSVERSION} >= 500038
@${ECHO} "WITH_RCORDER slapd(1) should start early in the boot process"
@@ -344,8 +361,7 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's,%LOCALSTATEDIR%/run/,${LDAP_RUN_DIR}/,g' \
- -e 's,\(back_[a-z]*\).la,\1,g' \
- ${WRKSRC}/servers/slapd/slapd.conf
+ ${SED_MODULES} ${WRKSRC}/servers/slapd/slapd.conf
.if defined(CONFIGURE_SED)
@${REINPLACE_CMD} -E ${CONFIGURE_SED} \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/net/openldap23-server/distinfo b/net/openldap23-server/distinfo
index 00c8773fd414..8734504e934e 100644
--- a/net/openldap23-server/distinfo
+++ b/net/openldap23-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (openldap-2.2.19.tgz) = e196c24c4eb714758c57d12f3b962bae
-SIZE (openldap-2.2.19.tgz) = 2601096
+MD5 (openldap-2.2.23.tgz) = 51d1cf0a8f77f5cd27a5aa2b82a344ec
+SIZE (openldap-2.2.23.tgz) = 2600908
diff --git a/net/openldap23-server/files/patch-configure b/net/openldap23-server/files/patch-configure
index 7f32b0a770b9..d25ea3f8bc5d 100644
--- a/net/openldap23-server/files/patch-configure
+++ b/net/openldap23-server/files/patch-configure
@@ -1,29 +1,20 @@
--- configure.orig Tue Jul 27 18:33:12 2004
+++ configure Sat Aug 14 17:05:23 2004
-@@ -20145,7 +20145,7 @@
-
-
- if test $ol_cv_bdb_compat = yes ; then
-- ol_enable_bdb=yes
-+ ol_enable_bdb=${ol_enable_bdb-yes}
- elif test $ol_enable_bdb = yes ; then
- { echo "configure: error: BDB: BerkeleyDB version incompatible" 1>&2; exit 1; }
- else
-@@ -20997,7 +20997,7 @@
+@@ -20985,7 +20985,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liodbc $LIBS"
+LIBS="-liodbc $LIBS $LTHREAD_LIBS"
cat > conftest.$ac_ext <<EOF
- #line 21003 "configure"
+ #line 20991 "configure"
#include "confdefs.h"
-@@ -21041,7 +21041,7 @@
+@@ -21029,7 +21029,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lodbc $LIBS"
+LIBS="-lodbc $LIBS $LTHREAD_LIBS"
cat > conftest.$ac_ext <<EOF
- #line 21047 "configure"
+ #line 21035 "configure"
#include "confdefs.h"
diff --git a/net/openldap23-server/files/patch-libraries::libldap::os-ip.c b/net/openldap23-server/files/patch-libraries::libldap::os-ip.c
new file mode 100644
index 000000000000..32df40c91e11
--- /dev/null
+++ b/net/openldap23-server/files/patch-libraries::libldap::os-ip.c
@@ -0,0 +1,23 @@
+--- libraries/libldap/os-ip.c Thu Jan 20 18:01:01 2005
++++ libraries/libldap/os-ip.c Mon Jan 31 16:53:39 2005
+@@ -258,15 +258,15 @@
+ if ( async ) return ( -2 );
+ #endif
+
+- FD_ZERO(&wfds);
+- FD_SET(s, &wfds );
++ do {
++ FD_ZERO(&wfds);
++ FD_SET(s, &wfds );
+
+ #ifdef HAVE_WINSOCK
+- FD_ZERO(&efds);
+- FD_SET(s, &efds );
++ FD_ZERO(&efds);
++ FD_SET(s, &efds );
+ #endif
+
+- do {
+ rc = select(ldap_int_tblsize, z, &wfds,
+ #ifdef HAVE_WINSOCK
+ &efds,
diff --git a/net/openldap23-server/files/patch-servers::slapd::back-ldap::search.c b/net/openldap23-server/files/patch-servers::slapd::back-ldap::search.c
new file mode 100644
index 000000000000..a519d2de3781
--- /dev/null
+++ b/net/openldap23-server/files/patch-servers::slapd::back-ldap::search.c
@@ -0,0 +1,11 @@
+--- servers/slapd/back-ldap/search.c Thu Jan 20 18:01:12 2005
++++ servers/slapd/back-ldap/search.c Wed Feb 2 14:51:05 2005
+@@ -681,7 +681,7 @@
+
+ retry:
+ rc = ldap_search_ext_s(lc->ld, mdn.bv_val, LDAP_SCOPE_BASE, filter,
+- gattr, 0, NULL, NULL, LDAP_NO_LIMIT,
++ at ? gattr : NULL, 0, NULL, NULL, LDAP_NO_LIMIT,
+ LDAP_NO_LIMIT, &result);
+ if ( rc != LDAP_SUCCESS ) {
+ if ( rc == LDAP_SERVER_DOWN && do_retry ) {