aboutsummaryrefslogtreecommitdiff
path: root/net/openldap24-server/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
commit5b55a8a53e383d5e641472b56a6d631e59da3967 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /net/openldap24-server/Makefile
parent769a9f1570ce818b49b6170bf5745363ffbe79e0 (diff)
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Notes
Notes: svn path=/head/; revision=416966
Diffstat (limited to 'net/openldap24-server/Makefile')
-rw-r--r--net/openldap24-server/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index efb6e65e5d9c..253aebe3b589 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -189,14 +189,6 @@ CONFIGURE_ARGS= --with-threads=posix \
# XXX FreeBSD does not implement O_DSYNC and fdatasync at this time.
CFLAGS+= -DMDB_DSYNC=O_SYNC -Dfdatasync=fsync
-.if !${PORT_OPTIONS:MFETCH}
-CONFIGURE_ARGS+= --without-fetch
-.else
-. if defined(OPENSSL_INSTALLED) && ${OPENSSL_INSTALLED} != "" || defined(WITH_OPENSSL_PORT)
-BROKEN= using OpenSSL from ports and OPTION FETCH together is not supported
-. endif
-.endif
-
.if ${PORT_OPTIONS:MSASL}
LIB_DEPENDS+= libsasl2.so:security/cyrus-sasl2
CONFIGURE_ARGS+= --with-cyrus-sasl
@@ -512,6 +504,16 @@ PLIST_SUB+= SHLIB_MAJOR=${OPENLDAP_SHLIB_MAJOR}
PLIST_SUB+= SHLIB_MINOR=${OPENLDAP_SHLIB_MINOR}
PLIST_SUB+= OPENLDAP_MAJOR=${OPENLDAP_MAJOR}
+.include <bsd.port.pre.mk>
+
+.if !${PORT_OPTIONS:MFETCH}
+CONFIGURE_ARGS+= --without-fetch
+.else
+. if defined(OPENSSL_INSTALLED) && ${OPENSSL_INSTALLED} != "" || ${SSL_DEFAULT} != base
+BROKEN= using OpenSSL from ports and OPTION FETCH together is not supported
+. endif
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%LOCALSTATEDIR%/run/|${LDAP_RUN_DIR}/|g' \
${SED_MODULES} ${WRKSRC}/servers/slapd/slapd.conf
@@ -588,4 +590,4 @@ post-install:
.endif
.endif # defined(CLIENT_ONLY)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>