aboutsummaryrefslogtreecommitdiff
path: root/net/openldap24-server
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-03-31 22:33:09 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-03-31 22:33:09 +0000
commit0ef511cb2ca8bd851d714320c7e3a50f92f96f72 (patch)
tree39c0dd0c3d266f3356835d3209347425c16318d8 /net/openldap24-server
parentc53e2d52d1991175c6cfe08e98b6f9743f46b2e1 (diff)
downloadports-0ef511cb2ca8bd851d714320c7e3a50f92f96f72.tar.gz
ports-0ef511cb2ca8bd851d714320c7e3a50f92f96f72.zip
Notes
Diffstat (limited to 'net/openldap24-server')
-rw-r--r--net/openldap24-server/Makefile88
-rw-r--r--net/openldap24-server/distinfo4
-rw-r--r--net/openldap24-server/files/patch-build::ltmain.sh17
-rw-r--r--net/openldap24-server/files/patch-build::top.mk12
-rw-r--r--net/openldap24-server/files/patch-build::version.var13
-rw-r--r--net/openldap24-server/pkg-install7
-rw-r--r--net/openldap24-server/pkg-plist4
-rw-r--r--net/openldap24-server/pkg-plist.client6
8 files changed, 107 insertions, 44 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 4b49a43df1de..6e2ece9c8c2c 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.7
+PORTVERSION= 2.2.8
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -33,17 +33,25 @@ MAINTAINER= eik@FreeBSD.org
COMMENT?= Open source LDAP server implementation
LATEST_LINK= ${PKGNAMEPREFIX}openldap22${PKGNAMESUFFIX}
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[013-9].*
WANT_OPENLDAP_VER?= 22
.if ${WANT_OPENLDAP_VER} != 22
BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
+PORTREVISION_CLIENT= 0
+PORTREVISION_SERVER= 0
+
+PKGNAMESUFFIX_CLIENT= -client
+PKGNAMESUFFIX_SERVER= -server
+
.if defined(CLIENT_ONLY)
-OPENLDAP_PORTREVISION= 3
-OPENLDAP_PKGNAMESUFFIX?=-client
-OPENLDAP_PKGFILESUFX?= .client
+OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
+OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_CLIENT}
+OPENLDAP_PKGFILESUFX= .client
+
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[013-9].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[013-9].*
.if !defined(NOPORTDOCS)
PORTDOCS= drafts rfc
@@ -53,12 +61,20 @@ PORTDOCS= drafts rfc
.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
.endif
.else
-OPENLDAP_PORTREVISION= 2
-OPENLDAP_PKGNAMESUFFIX?=-server
-OPENLDAP_PKGFILESUFX?=
+OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
+OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_SERVER}
+OPENLDAP_PKGFILESUFX=
RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-client
-CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].*
+#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
+CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[013-9].*
+
+.if ${PORTREVISION_CLIENT} != 0
+SUF1_CLIENT= _${PORTREVISION_CLIENT}
+.endif
+
+PKGNAME_CLIENT= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX_CLIENT}-${PORTVERSION}${SUF1_CLIENT}
.endif
USE_OPENSSL= yes
@@ -84,7 +100,8 @@ PLIST_SUB+= LDAP_RUN_DIR=${LDAP_RUN_DIR} \
DATABASEDIR=${DATABASEDIR} \
SLURPDIR=${SLURPDIR} \
-SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
+SED_SCRIPT= -e 's,%%PKGNAME%%,${PKGNAME},g' \
+ -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%LDAP_RUN_DIR%%,${LDAP_RUN_DIR},g' \
-e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
-e 's,%%SLURPDIR%%,${SLURPDIR},g'
@@ -94,6 +111,8 @@ CONFIGURE_ARGS= --with-threads=posix \
--enable-dynamic
.if defined(WITH_SASL)
+PKGNAMESUFFIX_CLIENT:= -sasl${PKGNAMESUFFIX_CLIENT}
+PKGNAMESUFFIX_SERVER:= -sasl${PKGNAMESUFFIX_SERVER}
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-cyrus-sasl
.else
@@ -110,6 +129,15 @@ INSTALLS_SHLIB= yes
.else
# server specific configuration
+USE_RC_SUBR= yes
+
+SED_SCRIPT+= -e 's,%%PKGNAME_CLIENT%%,${PKGNAME_CLIENT},g' \
+ -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
+ -e 's,%%RC_DIR%%,${RC_DIR},g' \
+ -e 's,%%RC_SUFX%%,${RC_SUFX},g'
+PLIST_SUB+= RC_DIR=${RC_DIR} \
+ RC_SUFX=${RC_SUFX}
+
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Makefile.in
CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
@@ -126,31 +154,30 @@ CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
CONFIGURE_ARGS+= --with-ldbm-api=bcompat \
--disable-bdb
.else
-CONFIGURE_ARGS+= --with-ldbm-api=berkeley
-
WITH_BDB_VER?= 42
.if ${WITH_BDB_VER} == 42
-LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+= --enable-bdb
+BDBLIB= db-4.2.2
.elif ${WITH_BDB_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
CONFIGURE_ARGS+= --enable-bdb
+BDBLIB= db41.1
.elif ${WITH_BDB_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
CONFIGURE_ARGS+= --disable-bdb
+BDBLIB= db4.0
.elif ${WITH_BDB_VER} == 3
-LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
CONFIGURE_ARGS+= --disable-bdb
+BDBLIB= db3.3
.else
.error WITH_BDB_VER must be 3, 4, 41 or 42
.endif
-.if ${WITH_BDB_VER} == 42
-LIBS+= -ldb-4.2
-.else
-LIBS+= -ldb${WITH_BDB_VER}
-.endif
+
+LIB_DEPENDS+= ${BDBLIB}:${PORTSDIR}/databases/db${WITH_BDB_VER}
CPPFLAGS+= -I${LOCALBASE}/include/db${WITH_BDB_VER}
+CONFIGURE_ARGS+= --with-ldbm-api=berkeley \
+ --enable-hdb
+CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDBLIB:R},' \
+ -e 's,(ol_cv_lib_db=)yes$$,\1-l${BDBLIB:R},'
.endif
.if defined(WITH_SHELL)
@@ -170,12 +197,11 @@ CONFIGURE_ARGS+= --enable-spasswd
WITH_ODBC_TYPE?= iODBC
.endif
.if defined(WITH_ODBC_TYPE)
+CONFIGURE_ARGS+= --enable-sql
.if ${WITH_ODBC_TYPE:L} == iodbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
-CONFIGURE_ARGS+= --enable-sql
.elif ${WITH_ODBC_TYPE:L} == unixodbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+= --enable-sql
.else
.error WITH_ODBC_TYPE must be iODBC or unixODBC
.endif
@@ -202,7 +228,7 @@ CONFIGURE_ARGS+= --enable-wrappers
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-LIBS+= ${PTHREAD_LIBS}
+#LIBS+= ${PTHREAD_LIBS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
@@ -215,20 +241,12 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
.include "${FILESDIR}/manpages"
.else
.if ${OSVERSION} >= 500038
-RC_SUBR?= ${DESTDIR}/etc/rc.subr
RC_DIR= ${DESTDIR}/etc/rc.d
RC_SUFX=
.else
-USE_RC_SUBR= yes
RC_DIR= ${PREFIX}/etc/rc.d
RC_SUFX= .sh
.endif
-
-SED_SCRIPT+= -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
- -e 's,%%RC_DIR%%,${RC_DIR},g' \
- -e 's,%%RC_SUFX%%,${RC_SUFX},g'
-PLIST_SUB+= RC_DIR=${RC_DIR} \
- RC_SUFX=${RC_SUFX}
.endif
pre-everything::
@@ -256,8 +274,10 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's,%LOCALSTATEDIR%/run/,${LDAP_RUN_DIR}/,g' \
${WRKSRC}/servers/slapd/slapd.conf
- @${REINPLACE_CMD} -Ee 's,^(ol_api_lib=)2\.2\.([0-9]+)$$,\1202:\2:200,' \
- ${WRKSRC}/build/version.var
+.if defined(CONFIGURE_SED)
+ @${REINPLACE_CMD} -E ${CONFIGURE_SED} \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind\(84\)\{0,1\}-base-8\.' 2>/dev/null`" ]; then \
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 0b3f58c13832..d1feb533eb8a 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (openldap-2.2.7.tgz) = 5669fcc8b263418b73a38b196b3463f1
-SIZE (openldap-2.2.7.tgz) = 2465692
+MD5 (openldap-2.2.8.tgz) = e22855a3e8d934df1afc9ebed5e913be
+SIZE (openldap-2.2.8.tgz) = 2503512
diff --git a/net/openldap24-server/files/patch-build::ltmain.sh b/net/openldap24-server/files/patch-build::ltmain.sh
index 69915180c4d9..515dd96d8756 100644
--- a/net/openldap24-server/files/patch-build::ltmain.sh
+++ b/net/openldap24-server/files/patch-build::ltmain.sh
@@ -1,5 +1,5 @@
--- build/ltmain.sh.orig Thu Jan 1 19:16:25 2004
-+++ build/ltmain.sh Thu Mar 25 11:55:10 2004
++++ build/ltmain.sh Sun Mar 28 14:58:06 2004
@@ -1076,7 +1076,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
@@ -9,7 +9,20 @@
# Do not include libc_r directly, use -pthread flag.
continue
;;
-@@ -4296,10 +4296,17 @@
+@@ -1088,6 +1088,12 @@
+
+ -module)
+ module=yes
++ case $host in
++ *-*-freebsd*)
++ # Do not build the useless static library
++ build_old_libs=no
++ ;;
++ esac
+ continue
+ ;;
+
+@@ -4296,10 +4302,17 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/net/openldap24-server/files/patch-build::top.mk b/net/openldap24-server/files/patch-build::top.mk
index 7eab45e9ea09..b6ec9f5e1657 100644
--- a/net/openldap24-server/files/patch-build::top.mk
+++ b/net/openldap24-server/files/patch-build::top.mk
@@ -1,15 +1,15 @@
---- build/top.mk.orig Wed Mar 17 21:15:31 2004
-+++ build/top.mk Wed Mar 24 03:37:31 2004
-@@ -68,7 +68,7 @@
-
+--- build/top.mk.orig Wed Mar 24 22:51:22 2004
++++ build/top.mk Wed Mar 31 22:28:53 2004
+@@ -69,7 +69,7 @@
LIBTOOL = @LIBTOOL@
+ LIBRELEASE = @OPENLDAP_LIBRELEASE@
LIBVERSION = @OPENLDAP_LIBVERSION@
--LTVERSION = -release $(LIBVERSION)
+-LTVERSION = -release $(LIBRELEASE) -version-info $(LIBVERSION)
+LTVERSION = -version-info $(LIBVERSION)
# libtool --only flag for libraries: platform specific
NT_LTONLY_LIB = # --only-$(BUILD_LIBS_DYNAMIC)
-@@ -190,6 +190,8 @@
+@@ -191,6 +191,8 @@
SLAPD_LIBS = @SLAPD_LIBS@ @SLAPD_PERL_LDFLAGS@ @SLAPD_SQL_LDFLAGS@ @SLAPD_SQL_LIBS@ @SLAPD_SLP_LIBS@
SLURPD_LIBS = @SLURPD_LIBS@
diff --git a/net/openldap24-server/files/patch-build::version.var b/net/openldap24-server/files/patch-build::version.var
new file mode 100644
index 000000000000..f4b6bc1ec6d5
--- /dev/null
+++ b/net/openldap24-server/files/patch-build::version.var
@@ -0,0 +1,13 @@
+--- build/version.var.orig Fri Mar 26 20:28:33 2004
++++ build/version.var Wed Mar 31 23:33:47 2004
+@@ -17,7 +17,7 @@
+ ol_minor=2
+ ol_patch=8
+ ol_api_inc=20208
+-ol_api_current=7
+-ol_api_revision=1
+-ol_api_age=0
++ol_api_current=202
++ol_api_revision=2
++ol_api_age=200
+ ol_release_date="2004/03/26"
diff --git a/net/openldap24-server/pkg-install b/net/openldap24-server/pkg-install
index ee0a9e8588bd..593e92c14a5e 100644
--- a/net/openldap24-server/pkg-install
+++ b/net/openldap24-server/pkg-install
@@ -6,12 +6,19 @@
CHOWN=/usr/sbin/chown
ECHO_CMD=echo
GREP=/usr/bin/grep
+PKG_INFO=/usr/sbin/pkg_info
PW=/usr/sbin/pw
FTPUSERS=/etc/ftpusers
case $2 in
PRE-INSTALL)
+ if ! ${PKG_INFO} -e '%%PKGNAME_CLIENT%%'; then
+ ${ECHO_CMD} "===> %%PKGNAME%% requires %%PKGNAME_CLIENT%%."
+ ${ECHO_CMD}
+ ${ECHO_CMD} " Please install %%PKGNAME_CLIENT%% manually."
+ exit 1
+ fi
if ! ${PW} usershow -n ldap >/dev/null 2>&1; then
${ECHO_CMD}
if ! ${PW} groupshow -n ldap >/dev/null 2>&1; then
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 3453338cd416..8ebdafd53d13 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -8,12 +8,16 @@ etc/openldap/slapd.conf.default
%%SLAPI%%lib/libslapi.a
%%SLAPI%%lib/libslapi.so
%%SLAPI%%lib/libslapi.so.202
+@comment %%SLAPI%%lib/libslapi-2.2.so
+@comment %%SLAPI%%lib/libslapi-2.2.so.7
libexec/slapd
libexec/slurpd
sbin/slapadd
sbin/slapcat
+sbin/slapdn
sbin/slapindex
sbin/slappasswd
+sbin/slaptest
@exec mkdir -p %%LDAP_RUN_DIR%%
@unexec rmdir %%LDAP_RUN_DIR%% 2>/dev/null || true
@exec mkdir -p %%DATABASEDIR%%
diff --git a/net/openldap24-server/pkg-plist.client b/net/openldap24-server/pkg-plist.client
index 60dd1197847d..dcc079b0ec30 100644
--- a/net/openldap24-server/pkg-plist.client
+++ b/net/openldap24-server/pkg-plist.client
@@ -22,12 +22,18 @@ include/slapi-plugin.h
lib/liblber.a
lib/liblber.so
lib/liblber.so.202
+@comment lib/liblber-2.2.so
+@comment lib/liblber-2.2.so.7
lib/libldap.a
lib/libldap.so
lib/libldap.so.202
+@comment lib/libldap-2.2.so
+@comment lib/libldap-2.2.so.7
lib/libldap_r.a
lib/libldap_r.so
lib/libldap_r.so.202
+@comment lib/libldap_r-2.2.so
+@comment lib/libldap_r-2.2.so.7
share/openldap/ucdata/case.dat
share/openldap/ucdata/cmbcl.dat
share/openldap/ucdata/comp.dat