aboutsummaryrefslogtreecommitdiff
path: root/net/openmcu
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2000-11-22 13:53:23 +0000
committerRoger Hardiman <roger@FreeBSD.org>2000-11-22 13:53:23 +0000
commitf6574f11ad11e0f7ddc8edde2b6aa6c721a9a88b (patch)
tree6bdac029891340023ace2db28cc364eabe1e7c50 /net/openmcu
parent378778659c4527cf391d2d8df75e9a1b8b3101af (diff)
downloadports-f6574f11ad11e0f7ddc8edde2b6aa6c721a9a88b.tar.gz
ports-f6574f11ad11e0f7ddc8edde2b6aa6c721a9a88b.zip
Notes
Diffstat (limited to 'net/openmcu')
-rw-r--r--net/openmcu/Makefile34
-rw-r--r--net/openmcu/distinfo1
-rw-r--r--net/openmcu/pkg-comment1
-rw-r--r--net/openmcu/pkg-descr10
-rw-r--r--net/openmcu/pkg-plist1
5 files changed, 47 insertions, 0 deletions
diff --git a/net/openmcu/Makefile b/net/openmcu/Makefile
new file mode 100644
index 000000000000..9000cd731203
--- /dev/null
+++ b/net/openmcu/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: openmcu
+# Date created: Wed Nov 22 08:57:55 GMT 2000
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openmcu
+PORTVERSION= cvs.20001122
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= roger
+
+MAINTAINER= roger@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NOCLEANDEPENDS= yes
+
+USE_NEWGCC= yes
+USE_BISON= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/openmcu ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/openmcu/distinfo b/net/openmcu/distinfo
new file mode 100644
index 000000000000..6243576dbb79
--- /dev/null
+++ b/net/openmcu/distinfo
@@ -0,0 +1 @@
+MD5 (openmcu-cvs.20001122.tar.gz) = 3d35e8ee9dd4ccd24917463cdc27ab17
diff --git a/net/openmcu/pkg-comment b/net/openmcu/pkg-comment
new file mode 100644
index 000000000000..27e85f0d940a
--- /dev/null
+++ b/net/openmcu/pkg-comment
@@ -0,0 +1 @@
+The MCU Multipoint Conference Unit lets several people to take part in a H323 Video Conference or Audio call
diff --git a/net/openmcu/pkg-descr b/net/openmcu/pkg-descr
new file mode 100644
index 000000000000..43e91d00e21f
--- /dev/null
+++ b/net/openmcu/pkg-descr
@@ -0,0 +1,10 @@
+OpenMCU is a H323 Multipoint Conference Unit.
+
+It allows several people to take part in the same Video Conference or
+Internet Phone Call (VoIP) when using program using the H323 protocols.
+
+Applications using H323 include OpenH323, OhPhone and Microsoft's NetMeeting.
+
+It makes use of PWLib and the OpenH323 stack from Equivalence Ltd Pty
+
+WWW: http://www.openh323.org/
diff --git a/net/openmcu/pkg-plist b/net/openmcu/pkg-plist
new file mode 100644
index 000000000000..0d2bffe9cf84
--- /dev/null
+++ b/net/openmcu/pkg-plist
@@ -0,0 +1 @@
+bin/openmcu