aboutsummaryrefslogtreecommitdiff
path: root/net/openntpd
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2004-10-12 14:33:06 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2004-10-12 14:33:06 +0000
commiteb3725a3d2d82ac56697ececcc16ca247de25bee (patch)
tree13220e86f0f4f9cf25dd274e7b812f6394ca13b6 /net/openntpd
parentf7a1023a139d5c6f579ed042a2ab5bbe0f5898f0 (diff)
downloadports-eb3725a3d2d82ac56697ececcc16ca247de25bee.tar.gz
ports-eb3725a3d2d82ac56697ececcc16ca247de25bee.zip
Notes
Diffstat (limited to 'net/openntpd')
-rw-r--r--net/openntpd/Makefile5
-rw-r--r--net/openntpd/distinfo4
-rw-r--r--net/openntpd/files/patch-config.c17
3 files changed, 22 insertions, 4 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index a73e987042e1..247b5b932a45 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= openntpd
-PORTVERSION= 20040719p
+PORTVERSION= 20040824p
CATEGORIES= net
-MASTER_SITES= http://www.zip.com.au/~dtucker/openntpd/ \
+MASTER_SITES= http://www.openntpd.org/dist/portable/ \
+ http://www.zip.com.au/~dtucker/openntpd/ \
http://dtucker.freeshell.org/openntpd/
MAINTAINER= naddy@FreeBSD.org
diff --git a/net/openntpd/distinfo b/net/openntpd/distinfo
index 27579680603e..e398e6d3f30c 100644
--- a/net/openntpd/distinfo
+++ b/net/openntpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (openntpd-20040719p.tar.gz) = c0d1dceb0e97e6ff38a2bcebec051dcd
-SIZE (openntpd-20040719p.tar.gz) = 105460
+MD5 (openntpd-20040824p.tar.gz) = 21045982ea8183515a683a13d6c17dbd
+SIZE (openntpd-20040824p.tar.gz) = 105638
diff --git a/net/openntpd/files/patch-config.c b/net/openntpd/files/patch-config.c
new file mode 100644
index 000000000000..db63ae348861
--- /dev/null
+++ b/net/openntpd/files/patch-config.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- config.c.orig Fri Aug 20 13:43:20 2004
++++ config.c Sat Sep 4 04:04:38 2004
+@@ -133,7 +133,11 @@
+ if (error) {
+ log_warnx("could not parse \"%s\": %s", s,
+ gai_strerror(error));
++#ifdef EAI_NODATA
+ if (error == EAI_AGAIN || error == EAI_NODATA)
++#else
++ if (error == EAI_AGAIN)
++#endif
+ return (0);
+ else
+ return (-1);