aboutsummaryrefslogtreecommitdiff
path: root/net/openntpd
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2017-09-07 21:23:00 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2017-09-07 21:23:00 +0000
commit6568d3ec19b8ac901b6f7edd0d74a1d364f586fa (patch)
treec06969819661cc09fcbbe3a028dab5711c4d63aa /net/openntpd
parent8bb9689668f888f42b8a5597c258f14929e71c72 (diff)
downloadports-6568d3ec19b8ac901b6f7edd0d74a1d364f586fa.tar.gz
ports-6568d3ec19b8ac901b6f7edd0d74a1d364f586fa.zip
Notes
Diffstat (limited to 'net/openntpd')
-rw-r--r--net/openntpd/Makefile3
-rw-r--r--net/openntpd/distinfo6
-rw-r--r--net/openntpd/files/patch-src_ntpd.815
-rw-r--r--net/openntpd/files/patch-src_parse.y23
4 files changed, 11 insertions, 36 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index fc01766f601a..98243188ac7c 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= openntpd
-PORTVERSION= 6.2p1
-PORTREVISION= 1
+PORTVERSION= 6.2p2
PORTEPOCH= 2
CATEGORIES= net
MASTER_SITES= OPENBSD/OpenNTPD
diff --git a/net/openntpd/distinfo b/net/openntpd/distinfo
index 901133fd9fbd..c6d00f38a02b 100644
--- a/net/openntpd/distinfo
+++ b/net/openntpd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500146749
-SHA256 (openntpd-6.2p1.tar.gz) = 05e1668f89969a6ae064f411cb1d864ca3acb27ebd8fac963e6443ea0788d0bc
-SIZE (openntpd-6.2p1.tar.gz) = 437376
+TIMESTAMP = 1504817543
+SHA256 (openntpd-6.2p2.tar.gz) = 5808a4137b008a4db20907e1a482f474734b120f254e3c5feb90db15e0820fb2
+SIZE (openntpd-6.2p2.tar.gz) = 437527
diff --git a/net/openntpd/files/patch-src_ntpd.8 b/net/openntpd/files/patch-src_ntpd.8
index 050631b2c2c3..61a3b8eed88c 100644
--- a/net/openntpd/files/patch-src_ntpd.8
+++ b/net/openntpd/files/patch-src_ntpd.8
@@ -1,4 +1,4 @@
---- src/ntpd.8.orig 2016-05-30 22:50:02 UTC
+--- src/ntpd.8.orig 2017-09-07 19:12:02 UTC
+++ src/ntpd.8
@@ -56,7 +56,7 @@ Use
.Ar file
@@ -9,7 +9,7 @@
.It Fl n
Configtest mode.
Only check the configuration file for validity.
-@@ -99,19 +99,19 @@ will be logged.
+@@ -99,18 +99,18 @@ will be logged.
After the local clock is synchronized,
.Nm
adjusts the clock frequency using the
@@ -18,13 +18,12 @@
system call to compensate for systematic drift.
.Pp
.Nm
- is usually started at boot time, and can be enabled by
- setting
+-is started at boot time by default via
-.Va ntpd_flags
++is usually started at boot time, and can be enabled by setting
+.Va openntpd_flags
in
--.Pa /etc/rc.conf.local .
-+.Pa /etc/rc.conf .
+ .Pa /etc/rc.conf .
See
.Xr rc 8
and
@@ -33,7 +32,7 @@
for more information on the boot process
and enabling daemons.
.Pp
-@@ -124,8 +124,8 @@ and its initial clock drift from
+@@ -123,8 +123,8 @@ and its initial clock drift from
.Pa /var/db/ntpd.drift .
Clock drift is periodically written to the drift file thereafter.
.Sh FILES
@@ -44,7 +43,7 @@
Default configuration file.
.It Pa /var/db/ntpd.drift
Drift file.
-@@ -135,12 +135,12 @@ Socket file for communication with
+@@ -134,12 +134,12 @@ Socket file for communication with
.El
.Sh SEE ALSO
.Xr date 1 ,
diff --git a/net/openntpd/files/patch-src_parse.y b/net/openntpd/files/patch-src_parse.y
deleted file mode 100644
index 0f1a3b912131..000000000000
--- a/net/openntpd/files/patch-src_parse.y
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/parse.y.orig 2017-08-11 19:19:57 UTC
-+++ src/parse.y
-@@ -136,6 +136,8 @@ main : LISTEN ON address listen_opts {
- struct sockaddr_in sin4;
- struct sockaddr_in6 sin6;
-
-+ memset(&sin4, 0, sizeof(sin4));
-+ memset(&sin6, 0, sizeof(sin6));
- sin4.sin_family = AF_INET;
- sin6.sin6_family = AF_INET6;
- #ifdef HAVE_STRUCT_SOCKADDR_IN_SIN_LEN
-@@ -144,9 +146,9 @@ main : LISTEN ON address listen_opts {
- #endif
-
- if (inet_pton(AF_INET, $3, &sin4.sin_addr) == 1)
-- memcpy(&query_addr4, &sin4, sizeof(struct in_addr));
-+ memcpy(&query_addr4, &sin4, sizeof(struct sockaddr_in));
- else if (inet_pton(AF_INET6, $3, &sin6.sin6_addr) == 1)
-- memcpy(&query_addr6, &sin6, sizeof(struct in6_addr));
-+ memcpy(&query_addr6, &sin6, sizeof(struct sockaddr_in6));
- else {
- yyerror("invalid IPv4 or IPv6 address: %s\n",
- $3);