aboutsummaryrefslogtreecommitdiff
path: root/net/openradius/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-01 08:02:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-01 08:02:14 +0000
commit21387ee9acfe5d1999bf2910e637d95a653a5957 (patch)
treea3d872b377afbc6fb2e02791eac248bc4202a552 /net/openradius/Makefile
parent61c3c7b866bb31161dcdfc54b41df8a450ccba68 (diff)
downloadports-21387ee9acfe5d1999bf2910e637d95a653a5957.tar.gz
ports-21387ee9acfe5d1999bf2910e637d95a653a5957.zip
Notes
Diffstat (limited to 'net/openradius/Makefile')
-rw-r--r--net/openradius/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/net/openradius/Makefile b/net/openradius/Makefile
index b55828529c73..e586dbc4c5b4 100644
--- a/net/openradius/Makefile
+++ b/net/openradius/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= openradius
-PORTVERSION= 0.9.10
-PORTREVISION= 2
+PORTVERSION= 0.9.12b
CATEGORIES= net
MASTER_SITES= http://www.xs4all.nl/~evbergen/openradius/download/ \
http://www.mirrors.wiretapped.net/security/authentication/radius/openradius/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= babak@farrokhi.net
COMMENT= A RADIUS server with some actual documentation
LOGFILE?= /var/log/openradius.log
@@ -46,6 +45,7 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/async-iface-notes ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/language.html ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/module-interface.html ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/note-behaviourfile ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/note-struct-ownership ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/using-openradius.html ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-ldap ${EXAMPLESDIR}
@@ -54,14 +54,12 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-postgres ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-unixpass ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-usersfile ${EXAMPLESDIR}
- ${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-usersfile-longpass ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/configuration.sample-ldap ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/configuration.sample-ldap-authbind ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/configuration.sample-mysql ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/configuration.sample-postgres ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/configuration.sample-unixpass ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/configuration.sample-usersfile ${EXAMPLESDIR}
- ${INSTALL_MAN} ${WRKSRC}/examples/redhat-sysv-init-script ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/accounts/README ${EXAMPLESDIR}/accounts
${INSTALL_MAN} ${WRKSRC}/examples/accounts/accounts.mysql ${EXAMPLESDIR}/accounts
${INSTALL_MAN} ${WRKSRC}/examples/accounts/behaviour ${EXAMPLESDIR}/accounts
@@ -69,7 +67,7 @@ post-install:
.endif
# Configuration, copy over to sample files
${MKDIR} ${PREFIX}/etc/${PORTNAME}
-.for FILE in dictionary behaviour configuration
+.for FILE in dictionary
${INSTALL_DATA} ${WRKSRC}/etc/${FILE} \
${PREFIX}/etc/${PORTNAME}/${FILE}.sample
.endfor
@@ -79,6 +77,19 @@ post-install:
${INSTALL} -m 0600 ${WRKSRC}/etc/legacy/${FILE} \
${PREFIX}/etc/${PORTNAME}/legacy/${FILE}.sample
.endfor
+
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}/modules
+.for FILE in radldap.attrmap
+ ${INSTALL} -m 0600 ${WRKSRC}/etc/modules/${FILE} \
+ ${PREFIX}/etc/${PORTNAME}/modules/${FILE}.sample
+.endfor
+
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}/subdicts
+.for FILE in dict.*
+ ${INSTALL} -m 0600 ${WRKSRC}/etc/subdicts/${FILE} \
+ ${PREFIX}/etc/${PORTNAME}/subdicts/
+.endfor
+
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}