aboutsummaryrefslogtreecommitdiff
path: root/net/openradius
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-08-28 17:03:24 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-08-28 17:03:24 +0000
commitc00e2c03af742375c54cbc26029ad4246c5d65df (patch)
tree89e12f24ad9d2a2e286ae86949669d8e20f6b9fc /net/openradius
parent7f3db1e438d4e03906ab559ff79282320b053aca (diff)
downloadports-c00e2c03af742375c54cbc26029ad4246c5d65df.tar.gz
ports-c00e2c03af742375c54cbc26029ad4246c5d65df.zip
Notes
Diffstat (limited to 'net/openradius')
-rw-r--r--net/openradius/Makefile28
-rw-r--r--net/openradius/pkg-plist92
2 files changed, 59 insertions, 61 deletions
diff --git a/net/openradius/Makefile b/net/openradius/Makefile
index 49808a8e67b9..ebcdbb05a015 100644
--- a/net/openradius/Makefile
+++ b/net/openradius/Makefile
@@ -9,7 +9,7 @@ PORTNAME= openradius
PORTVERSION= 0.9.12c
PORTREVISION= 1
CATEGORIES= net
-MASTER_SITES= http://www.xs4all.nl/~evbergen/openradius/download/ \
+MASTER_SITES= http://evbergen.home.xs4all.nl/openradius/download/ \
http://www.mirrors.wiretapped.net/security/authentication/radius/openradius/
MAINTAINER= crees@FreeBSD.org
@@ -41,14 +41,16 @@ PLIST_SUB+= LDAP="@comment "
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
- ${MKDIR} ${EXAMPLESDIR}/accounts
${INSTALL_MAN} ${WRKSRC}/doc/async-iface-notes ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/language.html ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/module-interface.html ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/note-behaviourfile ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/note-struct-ownership ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/doc/using-openradius.html ${DOCSDIR}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/accounts
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-ldap ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-ldap-authbind ${EXAMPLESDIR}
${INSTALL_MAN} ${WRKSRC}/examples/behaviour.sample-mysql ${EXAMPLESDIR}
@@ -67,28 +69,24 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/examples/accounts/configuration ${EXAMPLESDIR}/accounts
.endif
# Configuration, copy over to sample files
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${MKDIR} ${ETCDIR}
.for FILE in dictionary
- ${INSTALL_DATA} ${WRKSRC}/etc/${FILE} \
- ${PREFIX}/etc/${PORTNAME}/${FILE}.sample
+ ${INSTALL_DATA} ${WRKSRC}/etc/${FILE} ${ETCDIR}/${FILE}.sample
.endfor
# Copy over legacy config files to sample
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}/legacy
+ ${MKDIR} ${ETCDIR}/legacy
.for FILE in clients nases realms users
- ${INSTALL} -m 0600 ${WRKSRC}/etc/legacy/${FILE} \
- ${PREFIX}/etc/${PORTNAME}/legacy/${FILE}.sample
+ ${INSTALL} -m 0600 ${WRKSRC}/etc/legacy/${FILE} ${ETCDIR}/legacy/${FILE}.sample
.endfor
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}/modules
+ ${MKDIR} ${ETCDIR}/modules
.for FILE in radldap.attrmap
- ${INSTALL} -m 0600 ${WRKSRC}/etc/modules/${FILE} \
- ${PREFIX}/etc/${PORTNAME}/modules/${FILE}.sample
+ ${INSTALL} -m 0600 ${WRKSRC}/etc/modules/${FILE} ${ETCDIR}/modules/${FILE}.sample
.endfor
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}/subdicts
+ ${MKDIR} ${ETCDIR}/subdicts
.for FILE in dict.*
- ${INSTALL} -m 0600 ${WRKSRC}/etc/subdicts/${FILE} \
- ${PREFIX}/etc/${PORTNAME}/subdicts/
+ ${INSTALL} -m 0600 ${WRKSRC}/etc/subdicts/${FILE} ${ETCDIR}/subdicts/
.endfor
@${ECHO_CMD}
diff --git a/net/openradius/pkg-plist b/net/openradius/pkg-plist
index cf7b36637b03..182d04da094f 100644
--- a/net/openradius/pkg-plist
+++ b/net/openradius/pkg-plist
@@ -3,30 +3,30 @@ bin/genmd5hexpasswd
bin/radaccttest
bin/radclient
bin/radtest
-etc/openradius/dictionary.sample
-etc/openradius/legacy/clients.sample
-etc/openradius/legacy/nases.sample
-etc/openradius/legacy/realms.sample
-etc/openradius/legacy/users.sample
-etc/openradius/modules/radldap.attrmap.sample
-etc/openradius/subdicts/dict.ascend
-etc/openradius/subdicts/dict.cisco
-etc/openradius/subdicts/dict.erx
-etc/openradius/subdicts/dict.garderos
-etc/openradius/subdicts/dict.internal
-etc/openradius/subdicts/dict.memory
-etc/openradius/subdicts/dict.microsoft
-etc/openradius/subdicts/dict.nomadix
-etc/openradius/subdicts/dict.rfc2869
-etc/openradius/subdicts/dict.rfc3580
-etc/openradius/subdicts/dict.stdacct
-etc/openradius/subdicts/dict.stdauth
-etc/openradius/subdicts/dict.str-ldap
-etc/openradius/subdicts/dict.tnova
-etc/openradius/subdicts/dict.tunnel
-etc/openradius/subdicts/dict.usr
-etc/openradius/subdicts/dict.vendors
-etc/openradius/subdicts/dict.wispr
+%%ETCDIR%%/dictionary.sample
+%%ETCDIR%%/legacy/clients.sample
+%%ETCDIR%%/legacy/nases.sample
+%%ETCDIR%%/legacy/realms.sample
+%%ETCDIR%%/legacy/users.sample
+%%ETCDIR%%/modules/radldap.attrmap.sample
+%%ETCDIR%%/subdicts/dict.ascend
+%%ETCDIR%%/subdicts/dict.cisco
+%%ETCDIR%%/subdicts/dict.erx
+%%ETCDIR%%/subdicts/dict.garderos
+%%ETCDIR%%/subdicts/dict.internal
+%%ETCDIR%%/subdicts/dict.memory
+%%ETCDIR%%/subdicts/dict.microsoft
+%%ETCDIR%%/subdicts/dict.nomadix
+%%ETCDIR%%/subdicts/dict.rfc2869
+%%ETCDIR%%/subdicts/dict.rfc3580
+%%ETCDIR%%/subdicts/dict.stdacct
+%%ETCDIR%%/subdicts/dict.stdauth
+%%ETCDIR%%/subdicts/dict.str-ldap
+%%ETCDIR%%/subdicts/dict.tnova
+%%ETCDIR%%/subdicts/dict.tunnel
+%%ETCDIR%%/subdicts/dict.usr
+%%ETCDIR%%/subdicts/dict.vendors
+%%ETCDIR%%/subdicts/dict.wispr
lib/openradius/ascfile
lib/openradius/delay
lib/openradius/radclient
@@ -41,27 +41,27 @@ sbin/radiusd
%%PORTDOCS%%%%DOCSDIR%%/note-behaviourfile
%%PORTDOCS%%%%DOCSDIR%%/note-struct-ownership
%%PORTDOCS%%%%DOCSDIR%%/using-openradius.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/accounts/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/accounts/accounts.mysql
-%%PORTDOCS%%%%EXAMPLESDIR%%/accounts/behaviour
-%%PORTDOCS%%%%EXAMPLESDIR%%/accounts/configuration
-%%PORTDOCS%%%%EXAMPLESDIR%%/behaviour.sample-ldap
-%%PORTDOCS%%%%EXAMPLESDIR%%/behaviour.sample-ldap-authbind
-%%PORTDOCS%%%%EXAMPLESDIR%%/behaviour.sample-mysql
-%%PORTDOCS%%%%EXAMPLESDIR%%/behaviour.sample-postgres
-%%PORTDOCS%%%%EXAMPLESDIR%%/behaviour.sample-unixpass
-%%PORTDOCS%%%%EXAMPLESDIR%%/behaviour.sample-usersfile
-%%PORTDOCS%%%%EXAMPLESDIR%%/configuration.sample-ldap
-%%PORTDOCS%%%%EXAMPLESDIR%%/configuration.sample-ldap-authbind
-%%PORTDOCS%%%%EXAMPLESDIR%%/configuration.sample-mysql
-%%PORTDOCS%%%%EXAMPLESDIR%%/configuration.sample-postgres
-%%PORTDOCS%%%%EXAMPLESDIR%%/configuration.sample-unixpass
-%%PORTDOCS%%%%EXAMPLESDIR%%/configuration.sample-usersfile
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/accounts
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/accounts/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/accounts/accounts.mysql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/accounts/behaviour
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/accounts/configuration
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/behaviour.sample-ldap
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/behaviour.sample-ldap-authbind
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/behaviour.sample-mysql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/behaviour.sample-postgres
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/behaviour.sample-unixpass
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/behaviour.sample-usersfile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configuration.sample-ldap
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configuration.sample-ldap-authbind
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configuration.sample-mysql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configuration.sample-postgres
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configuration.sample-unixpass
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configuration.sample-usersfile
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/accounts
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/openradius
-@dirrmtry etc/openradius/subdicts
-@dirrmtry etc/openradius/modules
-@dirrmtry etc/openradius/legacy
-@dirrmtry etc/openradius
+@dirrmtry %%ETCDIR%%/subdicts
+@dirrmtry %%ETCDIR%%/modules
+@dirrmtry %%ETCDIR%%/legacy
+@dirrmtry %%ETCDIR%%