aboutsummaryrefslogtreecommitdiff
path: root/net/openreg
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-06-06 20:51:54 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-06-06 20:51:54 +0000
commit40a0c4adf7f6bac78992afcfe7d367fc7c254552 (patch)
tree013a1d0857b839b67c3737491fddc3b9a5d96f1b /net/openreg
parent63ca844fca1bef8314a07edc01e4a0bab00f8407 (diff)
downloadports-40a0c4adf7f6bac78992afcfe7d367fc7c254552.tar.gz
ports-40a0c4adf7f6bac78992afcfe7d367fc7c254552.zip
Notes
Diffstat (limited to 'net/openreg')
-rw-r--r--net/openreg/Makefile43
-rw-r--r--net/openreg/distinfo1
-rw-r--r--net/openreg/pkg-descr19
-rw-r--r--net/openreg/pkg-message4
-rw-r--r--net/openreg/pkg-plist65
5 files changed, 132 insertions, 0 deletions
diff --git a/net/openreg/Makefile b/net/openreg/Makefile
new file mode 100644
index 000000000000..72390cb8fa22
--- /dev/null
+++ b/net/openreg/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: openreg
+# Date created: 6 June 2003
+# Whom: seanc
+#
+# $FreeBSD$
+#
+
+PORTNAME= openreg
+PORTVERSION= 1.0.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITE_SUBDIR= openreg
+
+MAINTAINER= seanc@FreeBSD.org
+COMMENT= Domain Registry software
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/stunnel:${PORTSDIR}/security/stunnel \
+ ${LOCALBASE}/sbin/named:${PORTSDIR}/net/bind9 \
+ ${LOCALBASE}/bin/postgres:${PORTSDIR}/${POSTGRESQL_PORT} \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= ${LOCALBASE}/include/isc/buffer.h:${PORTSDIR}/net/bind9
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+
+POSTGRESQL_PORT?= databases/postgresql7
+
+USE_OPENSSL= YES
+USE_PERL5= YES
+GNU_CONFIGURE= YES
+
+post-install:
+ @${MKDIR} ${DOCSDIR} ;\
+ ${CP} -r ${WRKSRC}/doc/ ${DOCSDIR} ;\
+ cd ${WRKSRC}/doc ;\
+ for file in `${FIND} ./ ! -type d` ; do \
+ printf "share/doc/${PORTNAME}/%s\n" $$file >> ${TMPPLIST} ;\
+ done ;\
+ for dir in `${FIND} ./ -type d -mindepth 1| sort -r` ; do \
+ printf "@dirrm share/doc/${PORTNAME}/%s\n" $$dir >> ${TMPPLIST} ;\
+ done
+ @${ECHO} "@dirrm share/doc/${PORTNAME}" >> ${TMPPLIST}
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/net/openreg/distinfo b/net/openreg/distinfo
new file mode 100644
index 000000000000..f37f635b9295
--- /dev/null
+++ b/net/openreg/distinfo
@@ -0,0 +1 @@
+MD5 (openreg-1.0.2.tar.gz) = 0c5ecff71a2c5eec1cb8bebd201a0897
diff --git a/net/openreg/pkg-descr b/net/openreg/pkg-descr
new file mode 100644
index 000000000000..319198847d02
--- /dev/null
+++ b/net/openreg/pkg-descr
@@ -0,0 +1,19 @@
+OpenReg is an implementation of a domain registry, such as might be
+used by top-level domain operators to manage the delegation of domains
+in a "shared registry" environment. OpenReg:
+
+*) supports the Extensible Provisioning Protocol (EPP), the IETF
+ standards-track protocol for interaction between registries and
+ registrars;
+
+*) is designed and debugged as a distributed multi-process system;
+
+*) supports PostgreSQL and is designed to accommodate to very large registries;
+
+*) publishes zone files to be served using BIND;
+
+*) gathers comprehensive profiling and load statistics;
+
+*) is published as free software, under a BSD-style licence.
+
+WWW: http://www.isc.org/products/OpenReg/
diff --git a/net/openreg/pkg-message b/net/openreg/pkg-message
new file mode 100644
index 000000000000..574130e35745
--- /dev/null
+++ b/net/openreg/pkg-message
@@ -0,0 +1,4 @@
+----------------------------------------------------------------------
+ Read ${PREFIX}/share/doc/openreg/INSTALL for details on how to
+ setup OpenReg and get it started.
+----------------------------------------------------------------------
diff --git a/net/openreg/pkg-plist b/net/openreg/pkg-plist
new file mode 100644
index 000000000000..f053b5cbea11
--- /dev/null
+++ b/net/openreg/pkg-plist
@@ -0,0 +1,65 @@
+lib/perl5/%%PERL_VER%%/man/man3/ISC::DBI.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Date.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Log.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::NameVerify.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Net::CRLF.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Net::LengthPrefix.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Net::Listen.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Random.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::SRS::DB.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::SRS::Version.3
+lib/perl5/%%PERL_VER%%/man/man3/ISC::Stats::Report.3
+lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Direct.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Direct/Connect.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Direct/Listen.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Group.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Group/Connect.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Message.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/DB/ReplicationMaster.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/DB/ReplicationSlave.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Date.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Log.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/NameVerify.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Net/CRLF.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Net/Connect.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Net/LengthPrefix.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Net/Listen.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Random.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/DB.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/EPPConnection.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/EPPParser.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/EPPRegistrar.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/EPPResultCode.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/EPPWriter.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/SAX/EPPHandler.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/Version.pm
+lib/perl5/site_perl/%%PERL_VER%%/ISC/Stats/Report.pm
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/ISC/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/ISC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Direct
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/CC/Group
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/CC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/DB
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/Net
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS/SAX
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/SRS
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC/Stats
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/ISC
+bin/group-sniff
+bin/epp-from-file
+sbin/msgq
+sbin/xaction
+sbin/epp-frontend
+sbin/whois
+sbin/replication-master
+sbin/write-zone
+sbin/stats-monitor
+sbin/log-monitor
+sbin/ka_msgq
+sbin/ka_xaction
+sbin/ka_epp-frontend
+sbin/ka_whois
+sbin/ka_write-zone
+sbin/ka_stats-monitor
+@unexec echo "If you are permanently removing this port, you should do a ``rm -f /var/log/openreg`` to remove the log file and ``rm -rf /usr/local/openreg`` to remove the openreg data files." | fmt