aboutsummaryrefslogtreecommitdiff
path: root/net/opensips
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-07-17 15:41:55 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-07-17 15:41:55 +0000
commitedab71186322366d803e7b0dd87ecc38e1644c52 (patch)
treeb3efc0631e14f6f3c4729686ca7538df401a4b5e /net/opensips
parent4d15abff1c52803ea20b57317ad1bf0ec5eb047b (diff)
downloadports-edab71186322366d803e7b0dd87ecc38e1644c52.tar.gz
ports-edab71186322366d803e7b0dd87ecc38e1644c52.zip
Notes
Diffstat (limited to 'net/opensips')
-rw-r--r--net/opensips/Makefile13
-rw-r--r--net/opensips/distinfo5
-rw-r--r--net/opensips/files/patch-Makefile38
-rw-r--r--net/opensips/files/patch-Makefile.defs16
-rw-r--r--net/opensips/files/patch-io_wait.h2
-rw-r--r--net/opensips/files/patch-mem__shm_mem.h2
-rw-r--r--net/opensips/files/patch-modules__proto_tls__proto_tls.c2
7 files changed, 40 insertions, 38 deletions
diff --git a/net/opensips/Makefile b/net/opensips/Makefile
index 017ba932b429..3acce74a975c 100644
--- a/net/opensips/Makefile
+++ b/net/opensips/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= opensips
-PORTVERSION= 2.1.2
-PORTREVISION= 1
+PORTVERSION= 2.1.3
CATEGORIES= net
MASTER_SITES= http://opensips.org/pub/opensips/${PORTVERSION}/
@@ -13,8 +12,6 @@ COMMENT= Open SIP Server
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libxml2.so:textproc/libxml2 \
libxmlrpc.so:net/xmlrpc-c \
libpcre.so:devel/pcre \
@@ -22,6 +19,8 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2 \
librabbitmq.so:net/rabbitmq-c-devel \
libhiredis.so:databases/hiredis \
libexpat.so:textproc/expat2 \
+ libpython2.7.so:lang/python27 \
+ libcurl.so:ftp/curl \
libjson-c.so:devel/json-c
BUILD_DEPENDS= ginstall:sysutils/coreutils \
gtar:archivers/gtar \
@@ -33,6 +32,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash \
${LOCALBASE}/bin/python2:lang/python2 \
${LOCALBASE}/bin/grep:textproc/gnugrep
+BROKEN_powerpc64= Does not build
+
GINSTALL= ginstall
WRKSRC= ${WRKDIR}/opensips-${PORTVERSION}
@@ -40,7 +41,7 @@ DOCSDIR= share/doc/opensips
USE_RC_SUBR= opensips
-USES= gmake perl5 pkgconfig shebangfix
+USES= gmake perl5 pkgconfig shebangfix ssl
USE_GCC= yes
NOPRECIOUSMAKEVARS= yes
@@ -59,7 +60,7 @@ MYSQL_USE= MYSQL=client
PGSQL_USES+= pgsql
PGSQL_BUILD_DEPENDS+= p5-DBD-Pg>=3.4:databases/p5-DBD-Pg
-RADIUS_BUILD_DEPENDS+= radiusclient:net/radiusclient
+RADIUS_LIB_DEPENDS+= libradiusclient-ng.so:net/radiusclient
HTTP_LIB_DEPENDS+= libmicrohttpd.so:www/libmicrohttpd
GEOIP_LIB_DEPENDS+= libGeoIP.so:net/GeoIP
MEMCACHED_LIB_DEPENDS+= libmemcached.so:databases/libmemcached
diff --git a/net/opensips/distinfo b/net/opensips/distinfo
index 3c2561301f81..74b7b575adbb 100644
--- a/net/opensips/distinfo
+++ b/net/opensips/distinfo
@@ -1,2 +1,3 @@
-SHA256 (opensips-2.1.2.tar.gz) = 0206af5c6ee3b33856a9c51cf982cecdd26334c3c32fac8e33eb88e9a62ad6e9
-SIZE (opensips-2.1.2.tar.gz) = 4935839
+TIMESTAMP = 1468420407
+SHA256 (opensips-2.1.3.tar.gz) = 43ad82f67c5a62a0978cabfd6d0eba05c9be29307e548fdae1731200d79a9229
+SIZE (opensips-2.1.3.tar.gz) = 4777142
diff --git a/net/opensips/files/patch-Makefile b/net/opensips/files/patch-Makefile
index 43f8edffda07..d03633616fd9 100644
--- a/net/opensips/files/patch-Makefile
+++ b/net/opensips/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2015-08-27 15:06:47 UTC
+--- Makefile.orig 2016-07-13 15:21:26 UTC
+++ Makefile
@@ -46,7 +46,7 @@ auto_gen=lex.yy.c cfg.tab.c #lexx, yac
# whether or not to install opensips.cfg or just opensips.cfg.default
@@ -9,31 +9,31 @@
#extra modules to exclude
skip_modules?=
-@@ -509,27 +509,14 @@ install-cfg: $(cfg-prefix)/$(cfg-dir)
- rm -fr $(cfg-prefix)/$(cfg-dir)$(NAME).cfg.sample0
- chmod 600 $(cfg-prefix)/$(cfg-dir)$(NAME).cfg.sample
- chmod 700 $(cfg-prefix)/$(cfg-dir)
+@@ -495,27 +495,14 @@ install-cfg: $(cfg_prefix)/$(cfg_dir)
+ rm -fr $(cfg_prefix)/$(cfg_dir)$(NAME).cfg.sample0
+ chmod 600 $(cfg_prefix)/$(cfg_dir)$(NAME).cfg.sample
+ chmod 700 $(cfg_prefix)/$(cfg_dir)
- if [ -z "${skip_cfg_install}" -a \
-- ! -f $(cfg-prefix)/$(cfg-dir)$(NAME).cfg ]; then \
-- mv -f $(cfg-prefix)/$(cfg-dir)$(NAME).cfg.sample \
-- $(cfg-prefix)/$(cfg-dir)$(NAME).cfg; \
+- ! -f $(cfg_prefix)/$(cfg_dir)$(NAME).cfg ]; then \
+- mv -f $(cfg_prefix)/$(cfg_dir)$(NAME).cfg.sample \
+- $(cfg_prefix)/$(cfg_dir)$(NAME).cfg; \
- fi
# opensipsctl config
- $(INSTALL_TOUCH) $(cfg-prefix)/$(cfg-dir)/opensipsctlrc.sample
+ $(INSTALL_TOUCH) $(cfg_prefix)/$(cfg_dir)/opensipsctlrc.sample
$(INSTALL_CFG) scripts/opensipsctlrc \
- $(cfg-prefix)/$(cfg-dir)/opensipsctlrc.sample
-- if [ ! -f $(cfg-prefix)/$(cfg-dir)/opensipsctlrc ]; then \
-- mv -f $(cfg-prefix)/$(cfg-dir)/opensipsctlrc.sample \
-- $(cfg-prefix)/$(cfg-dir)/opensipsctlrc; \
+ $(cfg_prefix)/$(cfg_dir)/opensipsctlrc.sample
+- if [ ! -f $(cfg_prefix)/$(cfg_dir)/opensipsctlrc ]; then \
+- mv -f $(cfg_prefix)/$(cfg_dir)/opensipsctlrc.sample \
+- $(cfg_prefix)/$(cfg_dir)/opensipsctlrc; \
- fi
# osipsconsole config
- $(INSTALL_TOUCH) $(cfg-prefix)/$(cfg-dir)/osipsconsolerc.sample
+ $(INSTALL_TOUCH) $(cfg_prefix)/$(cfg_dir)/osipsconsolerc.sample
$(INSTALL_CFG) scripts/osipsconsolerc \
- $(cfg-prefix)/$(cfg-dir)/osipsconsolerc.sample
-- if [ ! -f $(cfg-prefix)/$(cfg-dir)/osipsconsolerc ]; then \
-- mv -f $(cfg-prefix)/$(cfg-dir)/osipsconsolerc.sample \
-- $(cfg-prefix)/$(cfg-dir)/osipsconsolerc; \
+ $(cfg_prefix)/$(cfg_dir)/osipsconsolerc.sample
+- if [ ! -f $(cfg_prefix)/$(cfg_dir)/osipsconsolerc ]; then \
+- mv -f $(cfg_prefix)/$(cfg_dir)/osipsconsolerc.sample \
+- $(cfg_prefix)/$(cfg_dir)/osipsconsolerc; \
- fi
- install-console: $(bin-prefix)/$(bin-dir)
+ install-console: $(bin_prefix)/$(bin_dir)
# install osipsconsole
diff --git a/net/opensips/files/patch-Makefile.defs b/net/opensips/files/patch-Makefile.defs
index bc3b2e837b15..f29d952bfd85 100644
--- a/net/opensips/files/patch-Makefile.defs
+++ b/net/opensips/files/patch-Makefile.defs
@@ -1,4 +1,4 @@
---- Makefile.defs.orig 2015-08-27 15:06:47 UTC
+--- Makefile.defs.orig 2016-05-30 14:13:27 UTC
+++ Makefile.defs
@@ -118,6 +118,14 @@ ifeq ($(OS),solaris)
ISSMP ?= yes
@@ -21,10 +21,10 @@
endif
+endif
- OSREL = $(shell uname -r)
- # numerical version (good for comparisons: A.B.C => A*1000000+B*1000+C)
-@@ -162,6 +171,9 @@ cfg-dir = etc/$(MAIN_NAME)/
- bin-dir = sbin/
+ #set some vars from the environment (and not make builtins)
+ CC := $(shell echo "$${CC}")
+@@ -308,6 +317,9 @@ cfg_dir = etc/$(MAIN_NAME)/
+ bin_dir = sbin/
ARCH_B = $(shell echo $(ARCH) | sed -e 's/.*64.*/64b/')
+ifeq ($(OS),freebsd)
@@ -33,11 +33,11 @@
ifeq ($(ARCH_B),64b)
LIBDIR ?= lib64
else
-@@ -169,6 +181,7 @@ else
+@@ -315,6 +327,7 @@ else
# assume 32b - it is not really used further
ARCH_B=32b
endif
+endif
- lib-dir = $(LIBDIR)/$(MAIN_NAME)
- modules-dir = $(LIBDIR)/$(MAIN_NAME)/modules/
+ lib_dir = $(LIBDIR)/$(MAIN_NAME)
+ modules_dir = $(LIBDIR)/$(MAIN_NAME)/modules/
diff --git a/net/opensips/files/patch-io_wait.h b/net/opensips/files/patch-io_wait.h
index 3a1fbf8d92c0..efcacef1cb1b 100644
--- a/net/opensips/files/patch-io_wait.h
+++ b/net/opensips/files/patch-io_wait.h
@@ -1,4 +1,4 @@
---- io_wait.h.orig 2015-08-27 15:06:47 UTC
+--- io_wait.h.orig 2016-05-30 14:13:27 UTC
+++ io_wait.h
@@ -56,6 +56,9 @@
diff --git a/net/opensips/files/patch-mem__shm_mem.h b/net/opensips/files/patch-mem__shm_mem.h
index ee544c7b59a6..0cec5165b041 100644
--- a/net/opensips/files/patch-mem__shm_mem.h
+++ b/net/opensips/files/patch-mem__shm_mem.h
@@ -1,4 +1,4 @@
---- mem/shm_mem.h.orig 2015-08-27 15:06:47 UTC
+--- mem/shm_mem.h.orig 2016-05-30 14:13:27 UTC
+++ mem/shm_mem.h
@@ -62,6 +62,7 @@
#endif
diff --git a/net/opensips/files/patch-modules__proto_tls__proto_tls.c b/net/opensips/files/patch-modules__proto_tls__proto_tls.c
index 660093bba83a..266debe90040 100644
--- a/net/opensips/files/patch-modules__proto_tls__proto_tls.c
+++ b/net/opensips/files/patch-modules__proto_tls__proto_tls.c
@@ -1,4 +1,4 @@
---- modules/proto_tls/proto_tls.c.orig 2015-08-27 15:06:47 UTC
+--- modules/proto_tls/proto_tls.c.orig 2016-05-30 14:13:27 UTC
+++ modules/proto_tls/proto_tls.c
@@ -42,6 +42,7 @@
#include <openssl/opensslv.h>