aboutsummaryrefslogtreecommitdiff
path: root/net/openslp
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-02-08 03:55:12 +0000
committerPatrick Li <pat@FreeBSD.org>2002-02-08 03:55:12 +0000
commit186aa086032c24cb2993416c0a4252e654fe8369 (patch)
tree119681b7516f850f1e28763ac4cd91cd95954af3 /net/openslp
parent8091f48c62fad72bfcb45a283e8319df39082914 (diff)
downloadports-186aa086032c24cb2993416c0a4252e654fe8369.tar.gz
ports-186aa086032c24cb2993416c0a4252e654fe8369.zip
Notes
Diffstat (limited to 'net/openslp')
-rw-r--r--net/openslp/Makefile6
-rw-r--r--net/openslp/distinfo2
-rw-r--r--net/openslp/files/patch-aa8
-rw-r--r--net/openslp/files/patch-ltmain.sh25
4 files changed, 32 insertions, 9 deletions
diff --git a/net/openslp/Makefile b/net/openslp/Makefile
index 44dda564bd17..a5120df1faeb 100644
--- a/net/openslp/Makefile
+++ b/net/openslp/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= openslp
-PORTVERSION= 1.0.6
+PORTVERSION= 1.0.7
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openslp
MAINTAINER= marcus@marcuscom.com
-FIND?= /usr/bin/find
-
.if defined(WITH_SLP_SECURITY)
USE_OPENSSL= yes
.endif
@@ -22,6 +20,7 @@ USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/openslp \
--localstatedir=/var
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.if defined(WITH_SLP_SECURITY)
CONFIGURE_ARGS+= --enable-slpv2-security
@@ -31,7 +30,6 @@ CONFIGURE_ARGS+= --enable-slpv2-security
CONFIGURE_ARGS+= --enable-async-api
.endif
-USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
post-extract:
diff --git a/net/openslp/distinfo b/net/openslp/distinfo
index 655f8150fcd5..153df2406a25 100644
--- a/net/openslp/distinfo
+++ b/net/openslp/distinfo
@@ -1 +1 @@
-MD5 (openslp-1.0.6.tar.gz) = c9af809dbdf6cfd1f08d42d9fcfd2e1a
+MD5 (openslp-1.0.7.tar.gz) = 35c6d09272bb6be0658dd6982798d462
diff --git a/net/openslp/files/patch-aa b/net/openslp/files/patch-aa
index 397914612e17..3014ef8a9843 100644
--- a/net/openslp/files/patch-aa
+++ b/net/openslp/files/patch-aa
@@ -1,12 +1,12 @@
---- Makefile.in.orig Mon Dec 17 11:26:53 2001
-+++ Makefile.in Mon Dec 17 11:27:42 2001
+--- Makefile.in.orig Mon Jan 28 13:27:17 2002
++++ Makefile.in Thu Feb 7 13:50:38 2002
@@ -78,8 +78,7 @@
VERSION = @VERSION@
SUBDIRS = common libslpattr slpd libslp slptool test
--EXTRA_DIST = win32 doc etc README.W32
+-EXTRA_DIST = win32 doc etc README.W32 FAQ
-DOC_DIR = $(prefix)/doc/openslp-$(VERSION)
-+EXTRA_DIST = win32 etc README.W32
++EXTRA_DIST = win32 etc README.W32 FAQ
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_CLEAN_FILES = slp.list
diff --git a/net/openslp/files/patch-ltmain.sh b/net/openslp/files/patch-ltmain.sh
new file mode 100644
index 000000000000..2ac052749556
--- /dev/null
+++ b/net/openslp/files/patch-ltmain.sh
@@ -0,0 +1,25 @@
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"