aboutsummaryrefslogtreecommitdiff
path: root/net/opentracker
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2017-08-13 14:27:27 +0000
committerChris Rees <crees@FreeBSD.org>2017-08-13 14:27:27 +0000
commit90148e9f98ee7528db6ff1df319fa9daff3dfa9e (patch)
tree9639cfd70beb6a2fe92525ef69c66f5dac1d84a9 /net/opentracker
parent1f793c32c5b8cbf64fbbdce17237ed57fa0172bb (diff)
Update to latest git-- 9c7be324f5a4306dd81eab2f982f87e2c42ffdf1
PR: ports/197477
Notes
Notes: svn path=/head/; revision=447894
Diffstat (limited to 'net/opentracker')
-rw-r--r--net/opentracker/Makefile4
-rw-r--r--net/opentracker/distinfo5
-rw-r--r--net/opentracker/files/patch-Makefile21
-rw-r--r--net/opentracker/files/patch-ot_accesslist.c12
4 files changed, 12 insertions, 30 deletions
diff --git a/net/opentracker/Makefile b/net/opentracker/Makefile
index d5e15b24adff..690b430ad2c7 100644
--- a/net/opentracker/Makefile
+++ b/net/opentracker/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= opentracker
-PORTVERSION= 0.2010.05.30
-PORTREVISION= 1
+PORTVERSION= 0.2017.08.13
CATEGORIES= net
MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/ \
- https://www.glenbarber.us/ports/net/${PORTNAME}/
MAINTAINER= crees@FreeBSD.org
COMMENT= Free lightweight bittorrent tracker using libowfat
diff --git a/net/opentracker/distinfo b/net/opentracker/distinfo
index 6e9c95c24516..fdd7b9ca9799 100644
--- a/net/opentracker/distinfo
+++ b/net/opentracker/distinfo
@@ -1,2 +1,3 @@
-SHA256 (opentracker-0.2010.05.30.tar.bz2) = 53b111cafd101ead61fb2b26760935b66657e5eba9067e28115be325391ec0bc
-SIZE (opentracker-0.2010.05.30.tar.bz2) = 48228
+TIMESTAMP = 1502634309
+SHA256 (opentracker-0.2017.08.13.tar.bz2) = 3795a2aebaa4abc6d100e5cb510d2646a60624fb87cf770df547c0d8b428fe3e
+SIZE (opentracker-0.2017.08.13.tar.bz2) = 277504
diff --git a/net/opentracker/files/patch-Makefile b/net/opentracker/files/patch-Makefile
index d0fed3d54e64..8ec3d77678fa 100644
--- a/net/opentracker/files/patch-Makefile
+++ b/net/opentracker/files/patch-Makefile
@@ -1,6 +1,8 @@
---- Makefile.orig 2010-05-30 16:16:13.000000000 +0100
-+++ Makefile 2010-05-30 16:17:20.000000000 +0100
-@@ -8,14 +8,14 @@
+diff --git a/Makefile b/Makefile
+index da2c8f1..9b16f13 100644
+--- Makefile
++++ Makefile
+@@ -8,14 +8,14 @@ CC?=gcc
# LIBOWFAT_LIBRARY=$(PREFIX)/lib
# BSD flavour
@@ -21,16 +23,16 @@
BINDIR?=$(PREFIX)/bin
-@@ -35,7 +35,7 @@
- #FEATURES+=-DWANT_MODEST_FULLSCRAPES
+@@ -37,7 +37,7 @@ BINDIR?=$(PREFIX)/bin
#FEATURES+=-DWANT_SPOT_WOODPECKER
#FEATURES+=-DWANT_SYSLOGS
+ #FEATURES+=-DWANT_DEV_RANDOM
-FEATURES+=-DWANT_FULLSCRAPE
+#FEATURES+=-DWANT_FULLSCRAPE
#FEATURES+=-D_DEBUG_HTTPERROR
-@@ -56,14 +56,13 @@
+@@ -59,7 +59,7 @@ OBJECTS_proxy_debug = $(SOURCES_proxy:%.c=%.debug.o)
.SUFFIXES: .debug.o .o .c
@@ -39,10 +41,3 @@
CFLAGS_production = $(CFLAGS) $(OPTS_production) $(FEATURES)
CFLAGS_debug = $(CFLAGS) $(OPTS_debug) $(FEATURES)
-
- $(BINARY): $(OBJECTS) $(HEADERS)
- $(CC) -o $@ $(OBJECTS) $(LDFLAGS)
-- strip $@
- $(BINARY).debug: $(OBJECTS_debug) $(HEADERS)
- $(CC) -o $@ $(OBJECTS_debug) $(LDFLAGS)
- proxy: $(OBJECTS_proxy) $(HEADERS)
diff --git a/net/opentracker/files/patch-ot_accesslist.c b/net/opentracker/files/patch-ot_accesslist.c
deleted file mode 100644
index 246499770a3b..000000000000
--- a/net/opentracker/files/patch-ot_accesslist.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ot_accesslist.c.orig 2010-11-04 17:34:00.000000000 -0700
-+++ ot_accesslist.c 2010-11-04 17:51:33.000000000 -0700
-@@ -54,8 +54,7 @@
- return;
- }
-
-- /* No use to scan if there's not enough room for another full info_hash */
-- map_end = map + maplen - 40;
-+ map_end = map + maplen;
- read_offs = map;
-
- /* We do ignore anything that is not of the form "^[:xdigit:]{40}[^:xdigit:].*" */