aboutsummaryrefslogtreecommitdiff
path: root/net/ortp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-25 16:47:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-25 16:47:00 +0000
commitd1bb75a806af36bcadb25ad9904aef4cad2f8f65 (patch)
tree8f85731557179a8b63ee16e70b741993205e546a /net/ortp
parent7314f054883962040f0c096f08bb7877f467f3a2 (diff)
downloadports-d1bb75a806af36bcadb25ad9904aef4cad2f8f65.tar.gz
ports-d1bb75a806af36bcadb25ad9904aef4cad2f8f65.zip
Notes
Diffstat (limited to 'net/ortp')
-rw-r--r--net/ortp/Makefile9
-rw-r--r--net/ortp/distinfo6
-rw-r--r--net/ortp/files/patch-configure13
-rw-r--r--net/ortp/files/patch-ltmain.sh16
-rw-r--r--net/ortp/pkg-descr5
-rw-r--r--net/ortp/pkg-plist29
6 files changed, 29 insertions, 49 deletions
diff --git a/net/ortp/Makefile b/net/ortp/Makefile
index 6629a57df363..9ed000058ae7 100644
--- a/net/ortp/Makefile
+++ b/net/ortp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ortp
-PORTVERSION= 0.12.0
+PORTVERSION= 0.13.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= linphone/ortp/sources
@@ -17,6 +17,11 @@ COMMENT= A Real-time Transport Protocol (RTP) stack
USE_GNOME= glib20 pkgconfig gnomehack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+
+pre-install:
+.if defined(NOPORTDOCS)
+ ${RM} -rf ${WRKSRC}/docs/html
+.endif
.include <bsd.port.mk>
diff --git a/net/ortp/distinfo b/net/ortp/distinfo
index 3545e029ab7e..b02555057a8f 100644
--- a/net/ortp/distinfo
+++ b/net/ortp/distinfo
@@ -1,3 +1,3 @@
-MD5 (ortp-0.12.0.tar.gz) = c36142acaed25806824dd4fac1d666b3
-SHA256 (ortp-0.12.0.tar.gz) = 96763b6ce728e4cde4f681c42a2c51790630ec8583c71fe9217dbce04ad7a6b8
-SIZE (ortp-0.12.0.tar.gz) = 495355
+MD5 (ortp-0.13.0.tar.gz) = 8cb4731ad5044626e802116fbb2093ff
+SHA256 (ortp-0.13.0.tar.gz) = aef36873bd6e9c2c63f30d6d0e3564ac34a680d3930c1e9e4246985a4483371f
+SIZE (ortp-0.13.0.tar.gz) = 495642
diff --git a/net/ortp/files/patch-configure b/net/ortp/files/patch-configure
deleted file mode 100644
index 664c80ff1ec0..000000000000
--- a/net/ortp/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- configure 2003/10/20 01:30:00 1.1
-+++ configure 2003/10/20 01:30:12
-@@ -18396,6 +18396,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/ortp/files/patch-ltmain.sh b/net/ortp/files/patch-ltmain.sh
deleted file mode 100644
index cf5219c6f09d..000000000000
--- a/net/ortp/files/patch-ltmain.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh
-+++ ltmain.sh
-@@ -6005,8 +6005,8 @@
- # Install the pseudo-library for information purposes.
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
-- $show "$install_prog $instname $destdir/$name"
-- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+# $show "$install_prog $instname $destdir/$name"
-+# $run eval "$install_prog $instname $destdir/$name" || exit $?
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/ortp/pkg-descr b/net/ortp/pkg-descr
index feb3f5b4a573..afed6991eeed 100644
--- a/net/ortp/pkg-descr
+++ b/net/ortp/pkg-descr
@@ -12,10 +12,13 @@ Features:
* Implements blocking and non blocking IO for RTP sessions.
* Supports mutiplexing IO, so that hundreds of RTP sessions can be managed by
a single thread.
+ * Features an adaptive jitter algorithm for a receiver to adapt to the
+ clockrate of the sender.
* Supports part of RFC2833 for telephone events over RTP.
* The API is well documented using gtk-doc.
* Licensed under the Lesser Gnu Public License.
* RTCP messages sent periodically since 0.7.0 (compound packet including
sender report or receiver report + SDES)
+ * Includes an API to parse incoming RTCP packets.
-WWW: http://www.linphone.org/ortp/
+WWW: http://www.linphone.org/index.php/v2/code_review/ortp
diff --git a/net/ortp/pkg-plist b/net/ortp/pkg-plist
index e06b347afac3..f412a86fdfc6 100644
--- a/net/ortp/pkg-plist
+++ b/net/ortp/pkg-plist
@@ -12,21 +12,22 @@ include/ortp/stun.h
include/ortp/stun_udp.h
include/ortp/telephonyevents.h
lib/libortp.a
+lib/libortp.la
lib/libortp.so
lib/libortp.so.5
libdata/pkgconfig/ortp.pc
-%%DOCSDIR%%/book1.html
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/ortp-library-management-functions.html
-%%DOCSDIR%%/ortp-multiplexing-sessions---in-a-one-thread-design.html
-%%DOCSDIR%%/ortp-rtp-payloads-and-profiles.html
-%%DOCSDIR%%/ortp-rtpsession-api.html
-%%DOCSDIR%%/ortp-telephone-events---rfc2833-.html
-%%DOCSDIR%%/ortpapi.html
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/up.png
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/book1.html
+%%PORTDOCS%%%%DOCSDIR%%/home.png
+%%PORTDOCS%%%%DOCSDIR%%/index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/left.png
+%%PORTDOCS%%%%DOCSDIR%%/ortp-library-management-functions.html
+%%PORTDOCS%%%%DOCSDIR%%/ortp-multiplexing-sessions---in-a-one-thread-design.html
+%%PORTDOCS%%%%DOCSDIR%%/ortp-rtp-payloads-and-profiles.html
+%%PORTDOCS%%%%DOCSDIR%%/ortp-rtpsession-api.html
+%%PORTDOCS%%%%DOCSDIR%%/ortp-telephone-events---rfc2833-.html
+%%PORTDOCS%%%%DOCSDIR%%/ortpapi.html
+%%PORTDOCS%%%%DOCSDIR%%/right.png
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/up.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/ortp