aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Apache2-SOAP
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-01-27 13:45:26 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-01-27 13:45:26 +0000
commitc5db3926982f311448ef4effa0b2ff6e9d3318d4 (patch)
tree5f6fcb0136968b610fc990f1f424a7fbfe1cf786 /net/p5-Apache2-SOAP
parent36eaaa07b6c0c88272a97b61fab03f0646ef5205 (diff)
downloadports-c5db3926982f311448ef4effa0b2ff6e9d3318d4.tar.gz
ports-c5db3926982f311448ef4effa0b2ff6e9d3318d4.zip
Notes
Diffstat (limited to 'net/p5-Apache2-SOAP')
-rw-r--r--net/p5-Apache2-SOAP/Makefile38
-rw-r--r--net/p5-Apache2-SOAP/distinfo3
-rw-r--r--net/p5-Apache2-SOAP/pkg-descr4
-rw-r--r--net/p5-Apache2-SOAP/pkg-plist8
4 files changed, 53 insertions, 0 deletions
diff --git a/net/p5-Apache2-SOAP/Makefile b/net/p5-Apache2-SOAP/Makefile
new file mode 100644
index 000000000000..13c04580142b
--- /dev/null
+++ b/net/p5-Apache2-SOAP/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Apache2-SOAP
+# Date Created: 26 January 2006
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache2-SOAP
+PORTVERSION= 0.71
+CATEGORIES= net www perl5
+MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/CPAN/authors/id/R/RK/RKOBES/ \
+ http://cpan.mirror.solnet.ch/modules/by-module/File/RKOBES/ \
+ http://cpan.mirror.fr/modules/by-module/Apache2/ \
+ http://backpan.perl.org/authors/id/R/RK/RKOBES/ \
+ http://cpan.mirrorgeek.com/modules/by-category/10_File_Names_Systems_Locking/File/RKOBES/ \
+ http://cpan.stu.edu.tw/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/Apache2/
+MASTER_SITE_SUBDIR= Apache2
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Apache2 mod_perl2 SOAP Server
+
+PERL_CONFIGURE= YES
+USE_APACHE= 2.0+
+
+MAN3= Apache2::SOAP.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+BUILD_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS+= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Apache2-SOAP/distinfo b/net/p5-Apache2-SOAP/distinfo
new file mode 100644
index 000000000000..a6915a5e90e9
--- /dev/null
+++ b/net/p5-Apache2-SOAP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Apache2-SOAP-0.71.tar.gz) = 32737d950c44bdd38d611c5d2a532850
+SHA256 (Apache2-SOAP-0.71.tar.gz) = 0dba00de0987279b54489c979e70689fd8f7b4e955c41088a88f317650f3cb0d
+SIZE (Apache2-SOAP-0.71.tar.gz) = 5302
diff --git a/net/p5-Apache2-SOAP/pkg-descr b/net/p5-Apache2-SOAP/pkg-descr
new file mode 100644
index 000000000000..8ae4a5339d5a
--- /dev/null
+++ b/net/p5-Apache2-SOAP/pkg-descr
@@ -0,0 +1,4 @@
+Apache2 mod_perl2 SOAP server
+
+- Simun Mikecin
+numisemis@yahoo.com
diff --git a/net/p5-Apache2-SOAP/pkg-plist b/net/p5-Apache2-SOAP/pkg-plist
new file mode 100644
index 000000000000..22d088f2ffbb
--- /dev/null
+++ b/net/p5-Apache2-SOAP/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Apache2/SOAP.pm
+%%SITE_PERL%%/SOAP/Transport/HTTP2.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache2/SOAP/.packlist
+@dirrmtry %%SITE_PERL%%/Apache2
+@dirrmtry %%SITE_PERL%%/SOAP/Transport
+@dirrmtry %%SITE_PERL%%/SOAP
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache2/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache2