aboutsummaryrefslogtreecommitdiff
path: root/net/p5-BBS-Client/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-05-31 15:19:59 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-05-31 15:19:59 +0000
commit82808bf7732f4c6f0363fe445bf7ebad378828d0 (patch)
treeef64fd53b9f20fa75a24f80621efe535fd5dce74 /net/p5-BBS-Client/Makefile
parent70f57a740d49384cb6c8c9248c10d131e80b3364 (diff)
Add p5-BBS-Client 0.03, a Client Module For BBS Systems.
PR: ports/124129 Submitted by: Yi-Jheng, Lin <yzlin at cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=214030
Diffstat (limited to 'net/p5-BBS-Client/Makefile')
-rw-r--r--net/p5-BBS-Client/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/p5-BBS-Client/Makefile b/net/p5-BBS-Client/Makefile
new file mode 100644
index 000000000000..25072b20a3f8
--- /dev/null
+++ b/net/p5-BBS-Client/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-BBS-Client
+# Date created: 2008-05-30
+# Whom: Yi-Jheng, Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BBS-Client
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/C/CO/CORNELIUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A Client Module For BBS Systems
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= BBS::Client.3
+
+.include <bsd.port.mk>