aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Event-tcp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-19 11:15:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-19 11:15:59 +0000
commita737a379dc169c0dad5faa4afcc88417a8dc347b (patch)
tree348d5657db28b1e92107b6e62b2f3e268ec199be /net/p5-Event-tcp/Makefile
parent53cb351521c84cb3ad785bec170514836d9b2908 (diff)
downloadports-a737a379dc169c0dad5faa4afcc88417a8dc347b.tar.gz
ports-a737a379dc169c0dad5faa4afcc88417a8dc347b.zip
Notes
Diffstat (limited to 'net/p5-Event-tcp/Makefile')
-rw-r--r--net/p5-Event-tcp/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/p5-Event-tcp/Makefile b/net/p5-Event-tcp/Makefile
new file mode 100644
index 000000000000..e2b159240346
--- /dev/null
+++ b/net/p5-Event-tcp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Event-tcp
+# Date created: 2009-11-15
+# Whom: steinex
+#
+# $FreeBSD$
+#
+
+PORTNAME= Event-tcp
+PORTVERSION= 0.14
+CATEGORIES= net devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steinex@nognu.de
+COMMENT= Glue code to build client-server style TCP-based services
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
+ ${SITE_PERL}/${PERL_ARCH}/Ioctl.pm:${PORTSDIR}/devel/p5-Ioctl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Event::tcpsession.3
+
+.include <bsd.port.mk>