aboutsummaryrefslogtreecommitdiff
path: root/net/p5-File-Rsync
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 05:37:12 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 05:37:12 +0000
commit62767a8f1d05e635fabb6733ed7f630d56353557 (patch)
treeb89ea8b4d8ce61d659ae219e6d4b31c78f0a49b7 /net/p5-File-Rsync
parent04c1c42cf5f237a28c71d23089a9e7f63feb6b9f (diff)
downloadports-62767a8f1d05e635fabb6733ed7f630d56353557.tar.gz
ports-62767a8f1d05e635fabb6733ed7f630d56353557.zip
Notes
Diffstat (limited to 'net/p5-File-Rsync')
-rw-r--r--net/p5-File-Rsync/Makefile24
-rw-r--r--net/p5-File-Rsync/distinfo1
-rw-r--r--net/p5-File-Rsync/files/patch-Makefile.PL11
-rw-r--r--net/p5-File-Rsync/files/patch-makepm.PL38
-rw-r--r--net/p5-File-Rsync/pkg-comment1
-rw-r--r--net/p5-File-Rsync/pkg-descr10
-rw-r--r--net/p5-File-Rsync/pkg-plist7
7 files changed, 92 insertions, 0 deletions
diff --git a/net/p5-File-Rsync/Makefile b/net/p5-File-Rsync/Makefile
new file mode 100644
index 000000000000..429db31450d4
--- /dev/null
+++ b/net/p5-File-Rsync/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-File-Rsync
+# Date created: 20 May 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Rsync
+PORTVERSION= 0.19
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= File::Rsync.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-File-Rsync/distinfo b/net/p5-File-Rsync/distinfo
new file mode 100644
index 000000000000..01edaa136d7c
--- /dev/null
+++ b/net/p5-File-Rsync/distinfo
@@ -0,0 +1 @@
+MD5 (File-Rsync-0.19.tar.gz) = 7cbbc1388c2704d6d7041241b3f98917
diff --git a/net/p5-File-Rsync/files/patch-Makefile.PL b/net/p5-File-Rsync/files/patch-Makefile.PL
new file mode 100644
index 000000000000..a49c785cff0f
--- /dev/null
+++ b/net/p5-File-Rsync/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Sun May 20 10:30:46 2001
++++ Makefile.PL Sun May 20 10:33:25 2001
+@@ -16,7 +16,7 @@
+ DISTNAME => $DISTNAME,
+ AUTHOR => $AUTHOR,
+ ABSTRACT => $ABSTRACT,
+- PL_FILES => { 'makepm.PL' => 'Config.pm' },
++ PL_FILES => { 'makepm.PL ${LOCALBASE}' => 'Config.pm' },
+ PM => { 'Rsync.pm' => '$(INST_LIB)/File/Rsync.pm',
+ 'Config.pm' => '$(INST_ARCHLIB)/File/Rsync/Config.pm' },
+ dist => { COMPRESS => 'gzip', SUFFIX => 'gz' },
diff --git a/net/p5-File-Rsync/files/patch-makepm.PL b/net/p5-File-Rsync/files/patch-makepm.PL
new file mode 100644
index 000000000000..d08ec52455be
--- /dev/null
+++ b/net/p5-File-Rsync/files/patch-makepm.PL
@@ -0,0 +1,38 @@
+--- makepm.PL.orig Sun May 20 10:23:34 2001
++++ makepm.PL Sun May 20 10:30:05 2001
+@@ -1,32 +1,8 @@
+ # makepm.PL -- Builds Rsync.pm from Rsync.in. -*- perl -*-
+-sub find_rsync {
+- my @dirs = map { s/^$/./; $_ } split (':', $ENV{PATH});
+- push (@dirs, qw(/usr/local/bin /usr/bin /opt/bin));
+- for my $dir (@dirs) {
+- next unless -d $dir;
+- next unless -x "$dir/rsync";
+- return "$dir/rsync";
+- }
+-}
+ $|=1;
+-$RSYNC=&find_rsync;
+-print <<'EOT';
+-
+-File::Rsync needs to know the path to the rsync binary. This path is encoded
+-in the installed module as the default path to rsync (it can be overridden
+-at runtime). Please enter the full path to the rsync program or just hit
+-Enter if the guess is correct. (If you always want the module to depend on
+-the $PATH environment variable at runtime, just set the path to 'rsync'
+-(this is not recommended)).
+-
+-EOT
+-$RSYNC||='/usr/local/bin/rsync';
+-print "Path to rsync [$RSYNC]: ";
+-my $ans=<STDIN>;
+-chomp $ans;
+-$RSYNC=$ans || $RSYNC;
+-$RSYNC=~s/\\/\\\\/g;
+-$RSYNC=~s/\'/\\\'/g;
++$PREFIX=@ARGV[0];
++$RSYNC=$PREFIX . "/rsync";
++print "Path to rsync [$RSYNC]";
+ open IN,'Config.in' or die "Cannot read Config.in: $!\n";
+ open OUT,'>Config.pm' or die "Cannot write Config.pm: $!\n";
+ while (<IN>) {
diff --git a/net/p5-File-Rsync/pkg-comment b/net/p5-File-Rsync/pkg-comment
new file mode 100644
index 000000000000..48cf5dd71426
--- /dev/null
+++ b/net/p5-File-Rsync/pkg-comment
@@ -0,0 +1 @@
+Perl convenience wrapper for the rsync(1) program
diff --git a/net/p5-File-Rsync/pkg-descr b/net/p5-File-Rsync/pkg-descr
new file mode 100644
index 000000000000..14c5c581a19c
--- /dev/null
+++ b/net/p5-File-Rsync/pkg-descr
@@ -0,0 +1,10 @@
+The File::Rsync Perl module is a convenience wrapper to the rsync(1)
+command. It has wrappers for almost all the rsync commands and features,
+as well as detecting errors.
+
+For more details, type 'perldoc File::Rsync' or see the CPAN homepage:
+
+WWW: http://search.cpan.org/search?dist=File-Rsync
+
+- Pete
+petef@databits.net
diff --git a/net/p5-File-Rsync/pkg-plist b/net/p5-File-Rsync/pkg-plist
new file mode 100644
index 000000000000..1ae097638879
--- /dev/null
+++ b/net/p5-File-Rsync/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/File/Rsync.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/File/Rsync/Config.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Rsync/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Rsync
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/File/Rsync
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/File 2>/dev/null || true