aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Filesys-SmbClient
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-03-21 21:59:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-03-21 21:59:31 +0000
commit7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8 (patch)
tree2b6d3a0598b45365f230c6f61cf8d8d784b7016d /net/p5-Filesys-SmbClient
parent6b610ab5e04c7e7c7916ffe651ed9b7824436bca (diff)
downloadports-7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8.tar.gz
ports-7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8.zip
Notes
Diffstat (limited to 'net/p5-Filesys-SmbClient')
-rw-r--r--net/p5-Filesys-SmbClient/Makefile7
-rw-r--r--net/p5-Filesys-SmbClient/files/patch-Makefile.PL4
2 files changed, 7 insertions, 4 deletions
diff --git a/net/p5-Filesys-SmbClient/Makefile b/net/p5-Filesys-SmbClient/Makefile
index 0aadbc63f0ea..9d800a4804ea 100644
--- a/net/p5-Filesys-SmbClient/Makefile
+++ b/net/p5-Filesys-SmbClient/Makefile
@@ -11,14 +11,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface for access Samba filesystem with libsmclient.so
-LIB_DEPENDS= libsmbclient.so:net/samba-libsmbclient
+BROKEN= no member named close in struct _SMBCCTX
+
BUILD_DEPENDS= p5-Test-Simple>=0:devel/p5-Test-Simple
-USES= perl5
+USES= perl5 samba:lib
USE_PERL5= configure
post-patch:
@${REINPLACE_CMD} -i '' -e 's!%%LOCALBASE%%!${LOCALBASE}!g' \
+ -e 's!%%SAMBAINCLUDES%%!${SAMBAINCLUDES}!g' \
+ -e 's!%%SAMBALIBS%%!${SAMBALIBS}!g' \
${WRKSRC}/Makefile.PL
post-install:
diff --git a/net/p5-Filesys-SmbClient/files/patch-Makefile.PL b/net/p5-Filesys-SmbClient/files/patch-Makefile.PL
index e6124d9273ed..83968e5fc36c 100644
--- a/net/p5-Filesys-SmbClient/files/patch-Makefile.PL
+++ b/net/p5-Filesys-SmbClient/files/patch-Makefile.PL
@@ -34,8 +34,8 @@
-# Trace for debug
-$ans = prompt("Compile module with trace to STDERR ?", "no");
-if ($ans =~ /^y(es)?$/i) { $define = "-DVERBOSE"; }
-+my $include = '%%LOCALBASE%%/include/';
-+my $lib = '%%LOCALBASE%%/lib/';
++my $include = '%%SAMBAINCLUDES%%/';
++my $lib = '%%SAMBALIBS%%/';
# Create config.h for alloca via configure
-my $prefix = $include;