aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Frontier-RPC/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-07-01 16:02:52 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-07-01 16:02:52 +0000
commit4e8ea2752bf78b43fbccfa3f2aab62c5569cdaeb (patch)
treee873a33559af40c6a8cddff1dd9744baa64f2457 /net/p5-Frontier-RPC/Makefile
parent62ae9c3b7d71a7b68025b913cd5a6cbf8fd28af7 (diff)
Notes
Diffstat (limited to 'net/p5-Frontier-RPC/Makefile')
-rw-r--r--net/p5-Frontier-RPC/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/net/p5-Frontier-RPC/Makefile b/net/p5-Frontier-RPC/Makefile
index 172bfd722655..f13f7f2dfdab 100644
--- a/net/p5-Frontier-RPC/Makefile
+++ b/net/p5-Frontier-RPC/Makefile
@@ -7,12 +7,13 @@
#
PORTNAME= Frontier-RPC
-PORTVERSION= 0.06
+PORTVERSION= 0.07.b4
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
http://bitsko.slc.ut.us/~ken/xml-rpc/
MASTER_SITE_SUBDIR= Frontier
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.07b4
MAINTAINER= ijliao@FreeBSD.org
COMMENT= Frontier::RPC implements UserLand Software's XML RPC
@@ -22,6 +23,16 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-X
PERL_CONFIGURE= yes
-MAN3= Frontier::Client.3 Frontier::Daemon.3 Frontier::RPC2.3
+MAN3= Apache::XMLRPC.3 \
+ Frontier::Client.3 \
+ Frontier::Daemon.3 \
+ Frontier::RPC2.3 \
+ Frontier::Responder.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from www/p5-libwww
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>