aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Frontier-RPC/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-08 13:49:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-08 13:49:38 +0000
commit1ef9081e13a7afe50ffc8bd19d7b8423d8e1e3f7 (patch)
tree82c4201998f9e63dfb1d82638dea1fd55a71b0dc /net/p5-Frontier-RPC/Makefile
parent8f5432225b597a8e108b89955959259f6c65fc14 (diff)
add p5-Frontier-RPC
Frontier::RPC implements UserLand Software's XML RPC
Notes
Notes: svn path=/head/; revision=39260
Diffstat (limited to 'net/p5-Frontier-RPC/Makefile')
-rw-r--r--net/p5-Frontier-RPC/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/p5-Frontier-RPC/Makefile b/net/p5-Frontier-RPC/Makefile
new file mode 100644
index 000000000000..cce1d6f13020
--- /dev/null
+++ b/net/p5-Frontier-RPC/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: p5-Frontier-RPC
+# Date created: Mar 8, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Frontier-RPC
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://bitsko.slc.ut.us/~ken/xml-rpc/
+MASTER_SITE_SUBDIR= Frontier
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Frontier::Client.3 Frontier::Daemon.3 Frontier::RPC2.3
+
+.include <bsd.port.mk>