aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Google-SAML-Response/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-20 01:11:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-20 01:11:23 +0000
commit487caa0d2e434f535d5ff49fb09877c53d6b8534 (patch)
tree2aa3544d6e2fa4eda843e0fe6796d78c31fbaf4c /net/p5-Google-SAML-Response/Makefile
parent37a67cc3bc1e3d5dd32a934c768f2f7b5fc015d6 (diff)
downloadports-487caa0d2e434f535d5ff49fb09877c53d6b8534.tar.gz
ports-487caa0d2e434f535d5ff49fb09877c53d6b8534.zip
Notes
Diffstat (limited to 'net/p5-Google-SAML-Response/Makefile')
-rw-r--r--net/p5-Google-SAML-Response/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/net/p5-Google-SAML-Response/Makefile b/net/p5-Google-SAML-Response/Makefile
index 71fec533ff53..0f10c8b2aafb 100644
--- a/net/p5-Google-SAML-Response/Makefile
+++ b/net/p5-Google-SAML-Response/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Google-SAML-Response
-PORTVERSION= 0.10
+PORTVERSION= 0.11
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,15 +14,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= SAML responses for Google\'s SSO implementation
-RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
- p5-Crypt-OpenSSL-DSA>0:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
- p5-Crypt-OpenSSL-RSA>0:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
- p5-File-Which>0:${PORTSDIR}/sysutils/p5-File-Which \
- p5-Google-SAML-Request>0:${PORTSDIR}/net/p5-Google-SAML-Request \
- p5-TimeDate>0:${PORTSDIR}/devel/p5-TimeDate \
- p5-XML-CanonicalizeXML>0:${PORTSDIR}/textproc/p5-XML-CanonicalizeXML
-BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-DSA>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
+ p5-Crypt-OpenSSL-RSA>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
+ p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-Google-SAML-Request>=0:${PORTSDIR}/net/p5-Google-SAML-Request \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-XML-CanonicalizeXML>=0:${PORTSDIR}/textproc/p5-XML-CanonicalizeXML
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
PERL_CONFIGURE= yes
@@ -30,8 +32,11 @@ MAN3= Google::SAML::Response.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-Digest-SHA>0:${PORTSDIR}/security/p5-Digest-SHA
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
.endif
.include <bsd.port.post.mk>