aboutsummaryrefslogtreecommitdiff
path: root/net/p5-IC-Radius
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-19 02:28:28 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-19 02:28:28 +0000
commitab745b2db0020f54be89ca656dda9281e34f04e3 (patch)
treef44c505bc501f05f2095c052a098faf055f1f73b /net/p5-IC-Radius
parentbe4f1e908ad7ad84ad5b4ab113c310e039957195 (diff)
downloadports-ab745b2db0020f54be89ca656dda9281e34f04e3.tar.gz
ports-ab745b2db0020f54be89ca656dda9281e34f04e3.zip
Notes
Diffstat (limited to 'net/p5-IC-Radius')
-rw-r--r--net/p5-IC-Radius/Makefile24
-rw-r--r--net/p5-IC-Radius/distinfo1
-rw-r--r--net/p5-IC-Radius/files/patch-Radius.pm20
-rw-r--r--net/p5-IC-Radius/pkg-comment1
-rw-r--r--net/p5-IC-Radius/pkg-descr7
-rw-r--r--net/p5-IC-Radius/pkg-plist5
6 files changed, 58 insertions, 0 deletions
diff --git a/net/p5-IC-Radius/Makefile b/net/p5-IC-Radius/Makefile
new file mode 100644
index 000000000000..aadcd015120f
--- /dev/null
+++ b/net/p5-IC-Radius/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-IC-Radius
+# Date created: 27 Jun 2001
+# Whom: Sergey N. Voronkov <serg@tmn.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IC-Radius
+PORTVERSION= 0.4
+CATEGORIES= net perl5
+MASTER_SITES= ftp://ftp.innercite.com/pub/perl/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= serg@tmn.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= IC::Radius.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-IC-Radius/distinfo b/net/p5-IC-Radius/distinfo
new file mode 100644
index 000000000000..725f2e631a33
--- /dev/null
+++ b/net/p5-IC-Radius/distinfo
@@ -0,0 +1 @@
+MD5 (IC-Radius-0.4.tar.gz) = ecd7e2c89caac91c9167fd2c128b6d19
diff --git a/net/p5-IC-Radius/files/patch-Radius.pm b/net/p5-IC-Radius/files/patch-Radius.pm
new file mode 100644
index 000000000000..d29bc3d34fd0
--- /dev/null
+++ b/net/p5-IC-Radius/files/patch-Radius.pm
@@ -0,0 +1,20 @@
+--- Radius.pm.orig Thu Jul 5 14:20:54 2001
++++ Radius.pm Thu Jul 5 14:30:19 2001
+@@ -1038,7 +1038,7 @@
+
+ =item * I<sample>
+
+- $radius->insert_realm('flintstones.com', 'bedrock.com', 'bedrock', '1812', 'nostrip');
++ $radius->update_realm('flintstones.com', 'bedrock.com', 'bedrock', '1812', 'nostrip');
+
+ =item * I<return value>
+
+@@ -1778,7 +1778,7 @@
+
+ sub fetch_realm_options {
+ my $self = shift;
+- my @options = ('nostrip', 'dohints');
++ my @options = ('nostrip', 'dohints', 'loglocal');
+
+ return @options if wantarray;
+ return \@options;
diff --git a/net/p5-IC-Radius/pkg-comment b/net/p5-IC-Radius/pkg-comment
new file mode 100644
index 000000000000..5b0f134ebc9b
--- /dev/null
+++ b/net/p5-IC-Radius/pkg-comment
@@ -0,0 +1 @@
+A Perl5 extension for ICRADIUS Interface Module
diff --git a/net/p5-IC-Radius/pkg-descr b/net/p5-IC-Radius/pkg-descr
new file mode 100644
index 000000000000..8c246d76361b
--- /dev/null
+++ b/net/p5-IC-Radius/pkg-descr
@@ -0,0 +1,7 @@
+IC::Radius - ICRADIUS Interface Module
+
+The IC::Radius module provides functions for interfacing with ICRADIUS.
+
+### ICRADIUS Interface Module
+### Drew Wilder-Goodwin
+### 2001-04-24
diff --git a/net/p5-IC-Radius/pkg-plist b/net/p5-IC-Radius/pkg-plist
new file mode 100644
index 000000000000..780346a48d45
--- /dev/null
+++ b/net/p5-IC-Radius/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/IC/Radius.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IC/Radius/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IC/Radius
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/IC 2>/dev/null || true