aboutsummaryrefslogtreecommitdiff
path: root/net/p5-IO-Interface
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-05-15 20:48:06 +0000
committerXin LI <delphij@FreeBSD.org>2012-05-15 20:48:06 +0000
commit43a8fdff46c5900ca9f0607f0cb9a57527959f78 (patch)
tree0a9bdded40c4cc286e8c1cef969f721f9f747438 /net/p5-IO-Interface
parentf53ea122aab8c9d8d71be5018af113c7de335572 (diff)
downloadports-43a8fdff46c5900ca9f0607f0cb9a57527959f78.tar.gz
ports-43a8fdff46c5900ca9f0607f0cb9a57527959f78.zip
Notes
Diffstat (limited to 'net/p5-IO-Interface')
-rw-r--r--net/p5-IO-Interface/Makefile1
-rw-r--r--net/p5-IO-Interface/files/patch-Interface.xs27
2 files changed, 28 insertions, 0 deletions
diff --git a/net/p5-IO-Interface/Makefile b/net/p5-IO-Interface/Makefile
index 0e9755b4968a..a443485405ec 100644
--- a/net/p5-IO-Interface/Makefile
+++ b/net/p5-IO-Interface/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-Interface
PORTVERSION= 1.06
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/net/p5-IO-Interface/files/patch-Interface.xs b/net/p5-IO-Interface/files/patch-Interface.xs
new file mode 100644
index 000000000000..c89a9e85b3ef
--- /dev/null
+++ b/net/p5-IO-Interface/files/patch-Interface.xs
@@ -0,0 +1,27 @@
+--- ./Interface.xs.orig 2008-06-06 08:51:42.000000000 -0700
++++ ./Interface.xs 2012-05-15 13:16:22.856348098 -0700
+@@ -567,6 +567,7 @@
+ struct ifreq ifr;
+ #if (defined(USE_GETIFADDRS) && defined(HAVE_SOCKADDR_DL_STRUCT))
+ struct ifaddrs* ifap = NULL;
++ struct ifaddrs* saved_ifap = NULL;
+ struct sockaddr_dl* sdl;
+ sa_family_t family;
+ char *sdlname, *haddr, *s;
+@@ -581,6 +582,7 @@
+ #endif
+ #if (defined(USE_GETIFADDRS) && defined(HAVE_SOCKADDR_DL_STRUCT))
+ getifaddrs(&ifap);
++ saved_ifap = ifap;
+
+ while(1) {
+ if (ifap == NULL) break;
+@@ -595,7 +597,7 @@
+ }
+ ifap = ifap -> ifa_next;
+ }
+- freeifaddrs(ifap);
++ freeifaddrs(saved_ifap);
+
+ s = hwaddr;
+ s[0] = '\0';