aboutsummaryrefslogtreecommitdiff
path: root/net/p5-IO-Socket-INET6
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-07-30 00:32:53 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-07-30 00:32:53 +0000
commita3c5b614425a0157e8a3a65da0b95bb12c038975 (patch)
treed514ef598ffb180e85946fb4a2c65335d5be7097 /net/p5-IO-Socket-INET6
parent3c77f983e7c1bf6f0caa6c6207927c5c35b6f586 (diff)
downloadports-a3c5b614425a0157e8a3a65da0b95bb12c038975.tar.gz
ports-a3c5b614425a0157e8a3a65da0b95bb12c038975.zip
Notes
Diffstat (limited to 'net/p5-IO-Socket-INET6')
-rw-r--r--net/p5-IO-Socket-INET6/Makefile9
-rw-r--r--net/p5-IO-Socket-INET6/files/5.005_03.diff32
2 files changed, 40 insertions, 1 deletions
diff --git a/net/p5-IO-Socket-INET6/Makefile b/net/p5-IO-Socket-INET6/Makefile
index 9f0799b4a7da..0f885107c300 100644
--- a/net/p5-IO-Socket-INET6/Makefile
+++ b/net/p5-IO-Socket-INET6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-Socket-INET6
PORTVERSION= 2.51
+PORTREVISION= 1
CATEGORIES= net perl5 ipv6
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IO
@@ -22,4 +23,10 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/net/p5-IO-Socket-INET6/files/5.005_03.diff b/net/p5-IO-Socket-INET6/files/5.005_03.diff
new file mode 100644
index 000000000000..10dc9fa57dae
--- /dev/null
+++ b/net/p5-IO-Socket-INET6/files/5.005_03.diff
@@ -0,0 +1,32 @@
+
+$FreeBSD$
+
+--- INET6.pm.orig
++++ INET6.pm
+@@ -10,7 +10,7 @@
+ package IO::Socket::INET6;
+
+ use strict;
+-our(@ISA, $VERSION);
++use vars qw(@ISA $VERSION);
+ use IO::Socket;
+ use Socket;
+ use Socket6;
+@@ -22,7 +22,7 @@
+ $VERSION = "2.51";
+ #Purpose: allow protocol independent protocol and original interface.
+
+-my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
++my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
+
+ IO::Socket::INET6->register_domain( AF_INET6 );
+
+@@ -190,7 +190,7 @@
+ }
+
+ if ($arg->{ReusePort}) {
+- $sock->sockopt(SO_REUSEPORT,1) or
++ $sock->sockopt(0x0200,1) or
+ return _error($sock, $!, "sockopt: $!");
+ }
+