aboutsummaryrefslogtreecommitdiff
path: root/net/p5-JUNOScript
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-03-17 16:43:26 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-03-17 16:43:26 +0000
commit802816682ed9d3a1a39de7a5655068ea6f5f46d4 (patch)
tree8d6e97bf36ac3157d9f08fcf5af71d821bd99932 /net/p5-JUNOScript
parent27613298a17f6fedeb9d63d818678b42d568a517 (diff)
downloadports-802816682ed9d3a1a39de7a5655068ea6f5f46d4.tar.gz
ports-802816682ed9d3a1a39de7a5655068ea6f5f46d4.zip
Notes
Diffstat (limited to 'net/p5-JUNOScript')
-rw-r--r--net/p5-JUNOScript/Makefile100
-rw-r--r--net/p5-JUNOScript/distinfo1
-rw-r--r--net/p5-JUNOScript/pkg-comment1
-rw-r--r--net/p5-JUNOScript/pkg-descr6
-rw-r--r--net/p5-JUNOScript/pkg-plist21
5 files changed, 129 insertions, 0 deletions
diff --git a/net/p5-JUNOScript/Makefile b/net/p5-JUNOScript/Makefile
new file mode 100644
index 000000000000..f663f12afe6e
--- /dev/null
+++ b/net/p5-JUNOScript/Makefile
@@ -0,0 +1,100 @@
+# New ports collection makefile for: JUNOScript
+# Date created: 13. March 2002
+# Whom: jesper@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= JUNOScript
+PORTVERSION= 5.2R1.4
+CATEGORIES= net perl5
+MASTER_SITES= https://download.juniper.net/public/junoscript/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
+PKGNAMEPREFIX= p5-
+DISTNAME= junoscript-${PORTVERSION}-domestic
+
+MAINTAINER= jesper@FreeBSD.org
+
+PERL_BASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2 \
+ xml2:${PORTSDIR}/textproc/libxml2 \
+ xslt:${PORTSDIR}/textproc/libxslt
+BUILD_DEPENDS= ${PERL_BASE}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${PERL_BASE}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${PERL_BASE}/Convert/ASN1.pm:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ ${PERL_BASE}/Convert/PEM.pm:${PORTSDIR}/converters/p5-Convert-PEM \
+ ${PERL_BASE}/Convert/ASCII/Armor.pm:${PORTSDIR}/converters/p5-Convert-ASCII-Armour \
+ ${PERL_BASE}/Class/Loader.pm:${PORTSDIR}/devel/p5-Class-Loader \
+ ${PERL_BASE}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${PERL_BASE}/${PERL_ARCH}/IO/Tty.pm:${PORTSDIR}/devel/p5-IO-Tty \
+ ${PERL_BASE}/Parse/Yapp.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${PERL_BASE}/Sort/Versions.pm:${PORTSDIR}/devel/p5-Sort-Versions \
+ ${PERL_BASE}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32 \
+ ${PERL_BASE}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
+ ${PERL_BASE}/${PERL_ARCH}/Math/GMP.pm:${PORTSDIR}/math/p5-Math-GMP \
+ ${PERL_BASE}/Data/Buffer.pm:${PORTSDIR}/misc/p5-Data-Buffer \
+ ${PERL_BASE}/Net/FTP.pm:${PORTSDIR}/net/p5-libnet \
+ ${PERL_BASE}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${PERL_BASE}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble \
+ ${PERL_BASE}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
+ ${PERL_BASE}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
+ ${PERL_BASE}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
+ ${PERL_BASE}/Crypt/DES_EDE3.pm:${PORTSDIR}/security/p5-Crypt-DES_EDE3 \
+ ${PERL_BASE}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
+ ${PERL_BASE}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ ${PERL_BASE}/Crypt/Primes.pm:${PORTSDIR}/security/p5-Crypt-Primes \
+ ${PERL_BASE}/Crypt/Random.pm:${PORTSDIR}/security/p5-Crypt-Random \
+ ${PERL_BASE}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA \
+ ${PERL_BASE}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${PERL_BASE}/Digest/HMAC.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${PERL_BASE}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ openssl:${PORTSDIR}/security/openssl \
+ ${PERL_BASE}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${PERL_BASE}/Tie/EncryptedHash.pm:${PORTSDIR}/security/p5-Tie-EncryptedHash \
+ gtkdoc-scan:${PORTSDIR}/textproc/gtk-doc \
+ ${PERL_BASE}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${PERL_BASE}/XML/Perl2SAX.pm:${PORTSDIR}/textproc/p5-libxml \
+ ${PERL_BASE}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
+ ${PERL_BASE}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${PERL_BASE}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
+ ${PERL_BASE}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${PERL_BASE}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${PERL_BASE}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+# http://www.juniper.net/footerlegal.html
+RESTRICTED= "Redistribution not allowed"
+NO_PACKAGE= "Redistribution not allowed"
+NO_CDROM= "Redistribution not allowed"
+
+WRKSRC= ${WRKDIR}/junoscript-${PORTVERSION}
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= JUNOS::Access.3 \
+ JUNOS::Access::stubs.3 \
+ JUNOS::Access::ssl.3 \
+ JUNOS::Methods.3 \
+ JUNOS::Access::xnm.3 \
+ JUNOS::DOM::Parser.3 \
+ JUNOS::Access::clear_text.3 \
+ JUNOS::Access::telnet.3 \
+ JUNOS::Access::rsh.3 \
+ JUNOS::Response.3 \
+ JUNOS::Trace.3 \
+ JUNOS::Access::ssh.3 \
+ JUNOS::Device.3
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= may not be automatically fetched due to licensing\
+ restrictions. You MUST manually fetch the ${DISTNAME}${EXTRACT_SUFX} file\
+ from http://www.juniper.net/support/junoscript/ or\
+ https://download.juniper.net/public/junoscript/5.2R1.4/junoscript-5.2R1.4-domestic.tar.gz\
+ - once ${DISTFILES} has been downloaded, move it to\
+ ${DISTDIR} and then restart this build.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-JUNOScript/distinfo b/net/p5-JUNOScript/distinfo
new file mode 100644
index 000000000000..b1b4496f786d
--- /dev/null
+++ b/net/p5-JUNOScript/distinfo
@@ -0,0 +1 @@
+MD5 (junoscript-5.2R1.4-domestic.tar.gz) = 6ffbb5055c297c3a5fb32b3c59b9caf0
diff --git a/net/p5-JUNOScript/pkg-comment b/net/p5-JUNOScript/pkg-comment
new file mode 100644
index 000000000000..dcb6dbb2f93b
--- /dev/null
+++ b/net/p5-JUNOScript/pkg-comment
@@ -0,0 +1 @@
+API to exchange information with Juniper Networks routers
diff --git a/net/p5-JUNOScript/pkg-descr b/net/p5-JUNOScript/pkg-descr
new file mode 100644
index 000000000000..b919ddc6c194
--- /dev/null
+++ b/net/p5-JUNOScript/pkg-descr
@@ -0,0 +1,6 @@
+The JUNOScript application programming interface (API) is an Extensible
+Markup Language (XML) application that Juniper Networks routers use to
+exchange information with client applications. XML is a metalanguage for
+defining how to mark the organizational structures and individual elements
+in a data set or document with tags that describe the function of the
+structures and elements.
diff --git a/net/p5-JUNOScript/pkg-plist b/net/p5-JUNOScript/pkg-plist
new file mode 100644
index 000000000000..5399fe023811
--- /dev/null
+++ b/net/p5-JUNOScript/pkg-plist
@@ -0,0 +1,21 @@
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/stubs.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/ssl.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/xnm.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/clear_text.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/telnet.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/rsh.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access/ssh.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/5.2R1.4/jroute_methods.pl
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/5.2R1.4/jcrypto_methods.pl
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/5.2R1.4/jkernel_methods.pl
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Methods.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/DOM/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/version.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Response.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Trace.pm
+lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Device.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/JUNOS/5.2R1.4
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/JUNOS/Access
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/JUNOS/DOM
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/JUNOS