aboutsummaryrefslogtreecommitdiff
path: root/net/p5-MaxMind-DB-Writer
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-07 09:33:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-07 09:33:53 +0000
commit67169b7d045165590aedd93f14af7c0143a2f797 (patch)
tree76941f6fde9033ac442b8d7782b1df2e5662600a /net/p5-MaxMind-DB-Writer
parent24d205c0381c701d92b79eba36df4c14ba571449 (diff)
downloadports-67169b7d045165590aedd93f14af7c0143a2f797.tar.gz
ports-67169b7d045165590aedd93f14af7c0143a2f797.zip
Notes
Diffstat (limited to 'net/p5-MaxMind-DB-Writer')
-rw-r--r--net/p5-MaxMind-DB-Writer/Makefile43
-rw-r--r--net/p5-MaxMind-DB-Writer/distinfo2
-rw-r--r--net/p5-MaxMind-DB-Writer/pkg-descr4
-rw-r--r--net/p5-MaxMind-DB-Writer/pkg-plist8
4 files changed, 57 insertions, 0 deletions
diff --git a/net/p5-MaxMind-DB-Writer/Makefile b/net/p5-MaxMind-DB-Writer/Makefile
new file mode 100644
index 000000000000..99c008628fee
--- /dev/null
+++ b/net/p5-MaxMind-DB-Writer/Makefile
@@ -0,0 +1,43 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MaxMind-DB-Writer
+PORTVERSION= 0.080000
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MAXMIND
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Create MaxMind DB database files
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Data-Dumper-Concise>=0:${PORTSDIR}/devel/p5-Data-Dumper-Concise \
+ p5-Data-IEEE754>=0:${PORTSDIR}/devel/p5-Data-IEEE754 \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Math-Int128>=0.06:${PORTSDIR}/math/p5-Math-Int128 \
+ p5-MaxMind-DB-Common>=0.031003:${PORTSDIR}/net/p5-MaxMind-DB-Common \
+ p5-MaxMind-DB-Reader>=0:${PORTSDIR}/net/p5-MaxMind-DB-Reader \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Params-Validate>=0:${PORTSDIR}/devel/p5-MooseX-Params-Validate \
+ p5-MooseX-StrictConstructor>=0:${PORTSDIR}/devel/p5-MooseX-StrictConstructor \
+ p5-Net-Works>=0.20:${PORTSDIR}/net/p5-Net-Works \
+ p5-Sereal-Decoder>=0:${PORTSDIR}/converters/p5-Sereal-Decoder \
+ p5-Sereal-Encoder>=0:${PORTSDIR}/converters/p5-Sereal-Encoder \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Data-Printer>=0:${PORTSDIR}/devel/p5-Data-Printer \
+ p5-Devel-Refcount>=0:${PORTSDIR}/devel/p5-Devel-Refcount \
+ p5-List-AllUtils>=0:${PORTSDIR}/devel/p5-List-AllUtils \
+ p5-Test-Bits>=0:${PORTSDIR}/devel/p5-Test-Bits \
+ p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
+
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-MaxMind-DB-Writer/distinfo b/net/p5-MaxMind-DB-Writer/distinfo
new file mode 100644
index 000000000000..026b8aedf449
--- /dev/null
+++ b/net/p5-MaxMind-DB-Writer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MaxMind-DB-Writer-0.080000.tar.gz) = 546fba481c9fc796f6189e4ad8458dbf155fc2ad02fb40a94fec7bf9cef4bbfb
+SIZE (MaxMind-DB-Writer-0.080000.tar.gz) = 159631
diff --git a/net/p5-MaxMind-DB-Writer/pkg-descr b/net/p5-MaxMind-DB-Writer/pkg-descr
new file mode 100644
index 000000000000..bce23b66d4fd
--- /dev/null
+++ b/net/p5-MaxMind-DB-Writer/pkg-descr
@@ -0,0 +1,4 @@
+MaxMind::DB::Writer contains the code necessary to write MaxMind DB database
+files.
+
+WWW: http://search.cpan.org/dist/MaxMind-DB-Writer/
diff --git a/net/p5-MaxMind-DB-Writer/pkg-plist b/net/p5-MaxMind-DB-Writer/pkg-plist
new file mode 100644
index 000000000000..b7266ac6ebfa
--- /dev/null
+++ b/net/p5-MaxMind-DB-Writer/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_ARCH%%/MaxMind/DB/Writer.pm
+%%SITE_ARCH%%/MaxMind/DB/Writer/Serializer.pm
+%%SITE_ARCH%%/MaxMind/DB/Writer/Tree.pm
+%%SITE_ARCH%%/MaxMind/DB/Writer/Tree/Processor/VisualizeTree.pm
+%%SITE_ARCH%%/MaxMind/DB/Writer/Util.pm
+%%SITE_ARCH%%/auto/MaxMind/DB/Writer/Tree/Tree.so
+%%PERL5_MAN3%%/MaxMind::DB::Writer.3.gz
+%%PERL5_MAN3%%/MaxMind::DB::Writer::Tree.3.gz