aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-ARP
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-01-12 21:31:06 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-01-12 21:31:06 +0000
commit008a741273314a6d83e30da2b2fbc5e80aab51ad (patch)
tree2dc0de329254d2bb7b21b6534c18772257929d0d /net/p5-Net-ARP
parent7f7e66385f86bc321f6c688664b8b97e8c0b0dca (diff)
downloadports-008a741273314a6d83e30da2b2fbc5e80aab51ad.tar.gz
ports-008a741273314a6d83e30da2b2fbc5e80aab51ad.zip
Notes
Diffstat (limited to 'net/p5-Net-ARP')
-rw-r--r--net/p5-Net-ARP/Makefile4
-rw-r--r--net/p5-Net-ARP/distinfo6
-rw-r--r--net/p5-Net-ARP/files/patch-arp.h9
3 files changed, 14 insertions, 5 deletions
diff --git a/net/p5-Net-ARP/Makefile b/net/p5-Net-ARP/Makefile
index a65a245df871..1517b65b2d60 100644
--- a/net/p5-Net-ARP/Makefile
+++ b/net/p5-Net-ARP/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= Net-ARP
-PORTVERSION= 1.0
+PORTVERSION= 1.0.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
PKGNAMEPREFIX= p5-
EXTRACT_SUFX= .tgz
-MAINTAINER= tjs@cdpa.nsysu.edu.tw
+MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension for creating ARP packets
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-ARP/distinfo b/net/p5-Net-ARP/distinfo
index 386020cc9acf..0a698b505860 100644
--- a/net/p5-Net-ARP/distinfo
+++ b/net/p5-Net-ARP/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-ARP-1.0.tgz) = 3ba7596f5e7ba7cb98a1f0b726bfc3fe
-SHA256 (Net-ARP-1.0.tgz) = 8e2a961604bdc78d9df1ee38abaf354e378444f6cdd98c00b5b148ae02bb2b8d
-SIZE (Net-ARP-1.0.tgz) = 16239
+MD5 (Net-ARP-1.0.2.tgz) = e2036f722d949a81de9b77d9d6030f42
+SHA256 (Net-ARP-1.0.2.tgz) = 7d0a404df3014edeab470be4c304061bc0c89f4a9231d97aedc7fe74bd463a81
+SIZE (Net-ARP-1.0.2.tgz) = 16303
diff --git a/net/p5-Net-ARP/files/patch-arp.h b/net/p5-Net-ARP/files/patch-arp.h
new file mode 100644
index 000000000000..a3df58229a53
--- /dev/null
+++ b/net/p5-Net-ARP/files/patch-arp.h
@@ -0,0 +1,9 @@
+--- arp.h.orig 2008-01-06 21:14:49.000000000 +0800
++++ arp.h 2008-01-06 21:15:11.000000000 +0800
+@@ -55,4 +55,6 @@
+ u_char dest_ip[IP_ALEN]; // dest ip
+ };
+
++#ifndef __i386__
+ extern struct ether_addr *ether_aton (__const char *__asc) __THROW;
++#endif