aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-ARP
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-06-24 13:35:56 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-06-24 13:35:56 +0000
commitc261e36369197461c4c12a9b828479849413e20b (patch)
treee149f9087ee1b296a0036b28baa57ec1b48e3b10 /net/p5-Net-ARP
parent3e0a826f1a6c88a420094000fc4d58017c8b2578 (diff)
downloadports-c261e36369197461c4c12a9b828479849413e20b.tar.gz
ports-c261e36369197461c4c12a9b828479849413e20b.zip
Notes
Diffstat (limited to 'net/p5-Net-ARP')
-rw-r--r--net/p5-Net-ARP/Makefile8
-rw-r--r--net/p5-Net-ARP/files/patch-arp.h13
-rw-r--r--net/p5-Net-ARP/files/patch-arp_lookup_bsd.c11
-rw-r--r--net/p5-Net-ARP/files/patch-ppport.h10
4 files changed, 28 insertions, 14 deletions
diff --git a/net/p5-Net-ARP/Makefile b/net/p5-Net-ARP/Makefile
index 83e1ebc76fe6..25a330e971ad 100644
--- a/net/p5-Net-ARP/Makefile
+++ b/net/p5-Net-ARP/Makefile
@@ -21,10 +21,4 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAN3= Net::ARP.3
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= Does not compile on amd64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-ARP/files/patch-arp.h b/net/p5-Net-ARP/files/patch-arp.h
index a3df58229a53..312215782d18 100644
--- a/net/p5-Net-ARP/files/patch-arp.h
+++ b/net/p5-Net-ARP/files/patch-arp.h
@@ -1,9 +1,8 @@
---- arp.h.orig 2008-01-06 21:14:49.000000000 +0800
-+++ arp.h 2008-01-06 21:15:11.000000000 +0800
-@@ -55,4 +55,6 @@
+--- arp.h.orig 2007-08-16 09:38:44.000000000 +0200
++++ arp.h 2008-06-24 14:47:24.000000000 +0200
+@@ -54,5 +54,3 @@
+ u_char dest_add[ETH_ALEN]; // dest mac
u_char dest_ip[IP_ALEN]; // dest ip
};
-
-+#ifndef __i386__
- extern struct ether_addr *ether_aton (__const char *__asc) __THROW;
-+#endif
+-
+-extern struct ether_addr *ether_aton (__const char *__asc) __THROW;
diff --git a/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c b/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
new file mode 100644
index 000000000000..3e905ecb3281
--- /dev/null
+++ b/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
@@ -0,0 +1,11 @@
+--- arp_lookup_bsd.c.orig 2006-09-20 11:19:00.000000000 +0200
++++ arp_lookup_bsd.c 2008-06-24 14:57:10.000000000 +0200
+@@ -18,6 +18,8 @@
+ See the GNU General Public License for more details.
+ */
+
++#include <string.h>
++#include <stdlib.h>
+ #include <sys/file.h>
+ #include <sys/socket.h>
+ #include <net/if_dl.h>
diff --git a/net/p5-Net-ARP/files/patch-ppport.h b/net/p5-Net-ARP/files/patch-ppport.h
new file mode 100644
index 000000000000..b4e12507d8e8
--- /dev/null
+++ b/net/p5-Net-ARP/files/patch-ppport.h
@@ -0,0 +1,10 @@
+--- ppport.h.orig 2008-06-24 12:35:16.000000000 +0000
++++ ppport.h 2008-06-24 12:35:40.000000000 +0000
+@@ -220,6 +220,7 @@
+ /* Replace: 0 */
+ #endif
+
++#undef PERL_UNUSED_DECL
+ #ifdef HASATTRIBUTE
+ # if (defined(__GNUC__) && defined(__cplusplus)) || defined(__INTEL_COMPILER)
+ # define PERL_UNUSED_DECL