aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Address-Ethernet
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-23 14:38:49 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-23 14:38:49 +0000
commitb28e872893e6470860cd86b910dedcf8cbcd89b0 (patch)
tree53bcabed0ef4f19ef2ee56fe8f51d1d637b230d5 /net/p5-Net-Address-Ethernet
parent02f1a23b809e4b41fc82d02f1abe126a209cb6e9 (diff)
downloadports-b28e872893e6470860cd86b910dedcf8cbcd89b0.tar.gz
ports-b28e872893e6470860cd86b910dedcf8cbcd89b0.zip
Notes
Diffstat (limited to 'net/p5-Net-Address-Ethernet')
-rw-r--r--net/p5-Net-Address-Ethernet/Makefile31
-rw-r--r--net/p5-Net-Address-Ethernet/distinfo3
-rw-r--r--net/p5-Net-Address-Ethernet/pkg-descr3
-rw-r--r--net/p5-Net-Address-Ethernet/pkg-plist8
4 files changed, 45 insertions, 0 deletions
diff --git a/net/p5-Net-Address-Ethernet/Makefile b/net/p5-Net-Address-Ethernet/Makefile
new file mode 100644
index 000000000000..c78b545c4cda
--- /dev/null
+++ b/net/p5-Net-Address-Ethernet/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-Address-Ethernet
+# Date created: 2006-07-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Address-Ethernet
+PORTVERSION= 1.077
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Find hardware ethernet address
+
+RUN_DEPENDS= ${SITE_PERL}/Env/Path.pm:${PORTSDIR}/devel/p5-Env-Path \
+ ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Address::Ethernet.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+RUN_DEPENDS+= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Address-Ethernet/distinfo b/net/p5-Net-Address-Ethernet/distinfo
new file mode 100644
index 000000000000..ce5a124f34cb
--- /dev/null
+++ b/net/p5-Net-Address-Ethernet/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Address-Ethernet-1.077.tar.gz) = 1f9799a42da9e62ef40c4ded3cccb286
+SHA256 (Net-Address-Ethernet-1.077.tar.gz) = 008eba399635b25b1f516cb61d1aa1a648c184403327f5402adf15aca4298a78
+SIZE (Net-Address-Ethernet-1.077.tar.gz) = 15501
diff --git a/net/p5-Net-Address-Ethernet/pkg-descr b/net/p5-Net-Address-Ethernet/pkg-descr
new file mode 100644
index 000000000000..70fd88746eca
--- /dev/null
+++ b/net/p5-Net-Address-Ethernet/pkg-descr
@@ -0,0 +1,3 @@
+Net::Address::Ethernet - find hardware ethernet address.
+
+WWW: http://search.cpan.org/dist/Net-Address-Ethernet/
diff --git a/net/p5-Net-Address-Ethernet/pkg-plist b/net/p5-Net-Address-Ethernet/pkg-plist
new file mode 100644
index 000000000000..93a662a3603b
--- /dev/null
+++ b/net/p5-Net-Address-Ethernet/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Address/Ethernet/.packlist
+%%SITE_PERL%%/Net/Address/Ethernet.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Address/Ethernet
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Address
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Address
+@dirrmtry %%SITE_PERL%%/Net