aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Amazon-S3
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-03-25 13:29:40 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-03-25 13:29:40 +0000
commitaff2f6d877a6007b49dfc3fbad8285ff9e74e151 (patch)
treed4002361930df9ed3d5b0aa60c452dcfdc4152cd /net/p5-Net-Amazon-S3
parent8763d2b054a448cd4e0f375e892ee8309ba6c24f (diff)
downloadports-aff2f6d877a6007b49dfc3fbad8285ff9e74e151.tar.gz
ports-aff2f6d877a6007b49dfc3fbad8285ff9e74e151.zip
Notes
Diffstat (limited to 'net/p5-Net-Amazon-S3')
-rw-r--r--net/p5-Net-Amazon-S3/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/net/p5-Net-Amazon-S3/Makefile b/net/p5-Net-Amazon-S3/Makefile
index 416cfc7e6443..51370cb55145 100644
--- a/net/p5-Net-Amazon-S3/Makefile
+++ b/net/p5-Net-Amazon-S3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Amazon-S3
PORTVERSION= 0.43
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,23 +15,30 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Use the Amazon S3 - Simple Storage Service
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/Digest/MD5/File.pm:${PORTSDIR}/security/p5-Digest-MD5-File \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-LWP-UserAgent-Determined>=0:${PORTSDIR}/www/p5-LWP-UserAgent-Determined \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= p5-Digest-MD5-File>=0:${PORTSDIR}/security/p5-Digest-MD5-File
PERL_CONFIGURE= yes
MAN3= Net::Amazon::S3.3 Net::Amazon::S3::Bucket.3
+# remove unused prerequisite
+post-patch:
+.for f in META.yml Makefile.PL
+ @${REINPLACE_CMD} -e '/DateTime::Format::Strptime/d' ${WRKSRC}/${f}
+ @${RM} ${WRKSRC}/${f}.bak
+.endfor
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
.endif
.include <bsd.port.post.mk>