aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Appliance-Session
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-05-05 12:58:33 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-05-05 12:58:33 +0000
commit37e7a347af6983ac30d38aa17e7903340ea0ba0d (patch)
treede9e22493a9ce5f4f042d6ce7795dae6d5e3d9e9 /net/p5-Net-Appliance-Session
parenteec2de880bc2fc0c88bcabbeb5f57ba5e7bbb25d (diff)
Notes
Diffstat (limited to 'net/p5-Net-Appliance-Session')
-rw-r--r--net/p5-Net-Appliance-Session/Makefile46
-rw-r--r--net/p5-Net-Appliance-Session/distinfo3
-rw-r--r--net/p5-Net-Appliance-Session/pkg-descr6
-rw-r--r--net/p5-Net-Appliance-Session/pkg-plist26
4 files changed, 81 insertions, 0 deletions
diff --git a/net/p5-Net-Appliance-Session/Makefile b/net/p5-Net-Appliance-Session/Makefile
new file mode 100644
index 000000000000..362be1cebf63
--- /dev/null
+++ b/net/p5-Net-Appliance-Session/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: net/p5-Net-Appliance-Session
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Appliance-Session
+PORTVERSION= 1.36
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Run command-line sessions to network appliances
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Appliance/Phrasebook.pm:${PORTSDIR}/net/p5-Net-Appliance-Phrasebook \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Class/Accessor/Fast/Contained.pm:${PORTSDIR}/devel/p5-Class-Accessor-Fast-Contained \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/${PERL_ARCH}/IO/Pty.pm:${PORTSDIR}/devel/p5-IO-Tty \
+ ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Appliance::Session.3 \
+ Net::Appliance::Session::Cookbook.3 \
+ Net::Appliance::Session::Cookbook::Intro.3 \
+ Net::Appliance::Session::Cookbook::Recipe01.3 \
+ Net::Appliance::Session::Cookbook::Recipe02.3 \
+ Net::Appliance::Session::Cookbook::Recipe03.3 \
+ Net::Appliance::Session::Cookbook::Recipe04.3 \
+ Net::Appliance::Session::Cookbook::Recipe05.3 \
+ Net::Appliance::Session::Cookbook::Recipe06.3 \
+ Net::Appliance::Session::Cookbook::Recipe07.3 \
+ Net::Appliance::Session::Transport.3 \
+ Net::Appliance::Session::Transport::SSH.3 \
+ Net::Appliance::Session::Transport::Serial.3 \
+ Net::Appliance::Session::Transport::Telnet.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Appliance-Session/distinfo b/net/p5-Net-Appliance-Session/distinfo
new file mode 100644
index 000000000000..8fd41627772c
--- /dev/null
+++ b/net/p5-Net-Appliance-Session/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Appliance-Session-1.36.tar.gz) = 58a454954b7d3d3f2c2d0ad5a45dace3
+SHA256 (Net-Appliance-Session-1.36.tar.gz) = ee8951d19ef40c4e0feb781d529182b920d2d3c05d62e09a2b8061d41f76a777
+SIZE (Net-Appliance-Session-1.36.tar.gz) = 61521
diff --git a/net/p5-Net-Appliance-Session/pkg-descr b/net/p5-Net-Appliance-Session/pkg-descr
new file mode 100644
index 000000000000..c2d4bf6900f6
--- /dev/null
+++ b/net/p5-Net-Appliance-Session/pkg-descr
@@ -0,0 +1,6 @@
+Use this module to establish an interactive command-line session with a
+network appliance. There is special support for moving into privileged
+mode and configure mode, with all other commands being sent through a
+generic call to your session object.
+
+WWW: http://search.cpan.org/dist/Net-Appliance-Session/
diff --git a/net/p5-Net-Appliance-Session/pkg-plist b/net/p5-Net-Appliance-Session/pkg-plist
new file mode 100644
index 000000000000..4250cb2194a7
--- /dev/null
+++ b/net/p5-Net-Appliance-Session/pkg-plist
@@ -0,0 +1,26 @@
+%%SITE_PERL%%/Net/Appliance/Session.pm
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Intro.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe01.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe02.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe03.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe04.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe05.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe06.pod
+%%SITE_PERL%%/Net/Appliance/Session/Cookbook/Recipe07.pod
+%%SITE_PERL%%/Net/Appliance/Session/Engine.pm
+%%SITE_PERL%%/Net/Appliance/Session/Exceptions.pm
+%%SITE_PERL%%/Net/Appliance/Session/Transport.pm
+%%SITE_PERL%%/Net/Appliance/Session/Transport/SSH.pm
+%%SITE_PERL%%/Net/Appliance/Session/Transport/Serial.pm
+%%SITE_PERL%%/Net/Appliance/Session/Transport/Telnet.pm
+%%SITE_PERL%%/Net/Appliance/Session/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance/Session/.packlist
+@dirrmtry %%SITE_PERL%%/Net/Appliance/Session/Transport
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance/Session
+@dirrmtry %%SITE_PERL%%/Net/Appliance/Session/Cookbook
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance
+@dirrmtry %%SITE_PERL%%/Net/Appliance/Session
+@dirrmtry %%SITE_PERL%%/Net/Appliance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net