aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-CLI-Interact/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-01-30 19:47:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-01-30 19:47:29 +0000
commit3fed73f731644ecdd68adacad8c7f1466bc3de51 (patch)
tree0b105614a770502e01a452649d907b1dbe8ccda0 /net/p5-Net-CLI-Interact/Makefile
parent1b576d9b32f87b49c086d605359112656b5d5f98 (diff)
downloadports-3fed73f731644ecdd68adacad8c7f1466bc3de51.tar.gz
ports-3fed73f731644ecdd68adacad8c7f1466bc3de51.zip
Notes
Diffstat (limited to 'net/p5-Net-CLI-Interact/Makefile')
-rw-r--r--net/p5-Net-CLI-Interact/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/net/p5-Net-CLI-Interact/Makefile b/net/p5-Net-CLI-Interact/Makefile
index d06a9a19722a..773e9821e8ce 100644
--- a/net/p5-Net-CLI-Interact/Makefile
+++ b/net/p5-Net-CLI-Interact/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: p5-Net-CLI-Interact
-# Date created: 2011-10-05
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-CLI-Interact
-PORTVERSION= 1.122.100
+PORTVERSION= 2.123.620
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,11 +14,14 @@ COMMENT= Toolkit for CLI Automation
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-IO-Tty>=0:${PORTSDIR}/devel/p5-IO-Tty \
+BUILD_DEPENDS= p5-Class-Load>=0:${PORTSDIR}/devel/p5-Class-Load \
+ p5-Class-Mix>=0:${PORTSDIR}/devel/p5-Class-Mix \
+ p5-IO-Tty>=0:${PORTSDIR}/devel/p5-IO-Tty \
p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
p5-Log-Dispatch-Config>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Config \
p5-Log-Dispatch-Configurator-Any>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Configurator-Any \
- p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
+ p5-Moo>=0:${PORTSDIR}/devel/p5-Moo \
+ p5-MooX-Types-MooseLike>=0:${PORTSDIR}/devel/p5-MooX-Types-MooseLike \
p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -40,15 +39,10 @@ MAN3= Net::CLI::Interact.3 \
Net::CLI::Interact::Role::Engine.3 \
Net::CLI::Interact::Role::Iterator.3 \
Net::CLI::Interact::Role::Prompt.3 \
- Net::CLI::Interact::Transport.3 \
+ Net::CLI::Interact::Transport::Base.3 \
+ Net::CLI::Interact::Transport::Loopback.3 \
Net::CLI::Interact::Transport::SSH.3 \
Net::CLI::Interact::Transport::Serial.3 \
Net::CLI::Interact::Transport::Telnet.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>