aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-CSTA/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 03:55:32 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 03:55:32 +0000
commitb3d60d11fd485191eb16412d46baac3edfb07117 (patch)
tree236b0b802be6d04649d3b9a8526f36678b18bc66 /net/p5-Net-CSTA/Makefile
parent68823a7a68dd4efb837d33c2d3a6e3273e7a5f5a (diff)
Notes
Diffstat (limited to 'net/p5-Net-CSTA/Makefile')
-rw-r--r--net/p5-Net-CSTA/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/p5-Net-CSTA/Makefile b/net/p5-Net-CSTA/Makefile
new file mode 100644
index 000000000000..f2febed09a81
--- /dev/null
+++ b/net/p5-Net-CSTA/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-CSTA
+# Date created: 2006-07-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-CSTA
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for ECMA CSTA
+
+RUN_DEPENDS= ${SITE_PERL}/Convert/ASN1.pm:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::CSTA.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500701
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>