aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-DAV-Server
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-20 01:01:38 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-20 01:01:38 +0000
commit4321b21fedebf3a52a38e2845fb8b8723c60562d (patch)
tree9638bd8f132eb4582f4fd42ef9361a18a9788bcf /net/p5-Net-DAV-Server
parent7dfc5ecd1b23494d5a9bbe9ce44a0c2fc3f61ce8 (diff)
downloadports-4321b21fedebf3a52a38e2845fb8b8723c60562d.tar.gz
ports-4321b21fedebf3a52a38e2845fb8b8723c60562d.zip
Notes
Diffstat (limited to 'net/p5-Net-DAV-Server')
-rw-r--r--net/p5-Net-DAV-Server/Makefile47
-rw-r--r--net/p5-Net-DAV-Server/distinfo3
-rw-r--r--net/p5-Net-DAV-Server/pkg-descr16
-rw-r--r--net/p5-Net-DAV-Server/pkg-plist8
4 files changed, 74 insertions, 0 deletions
diff --git a/net/p5-Net-DAV-Server/Makefile b/net/p5-Net-DAV-Server/Makefile
new file mode 100644
index 000000000000..41b6e4262d2e
--- /dev/null
+++ b/net/p5-Net-DAV-Server/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Net-DAV-Server
+# Date created: 2006-07-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DAV-Server
+PORTVERSION= 1.29
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Provide a DAV Server
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/File/Find/Rule/Filesys/Virtual.pm:${PORTSDIR}/devel/p5-File-Find-Rule-Filesys-Virtual \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
+ ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/devel/p5-DateTime-Format-HTTP \
+ ${SITE_PERL}/HTTP/Headers.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Response.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DAV::Server.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500602 || ${PERL_LEVEL} == 500701
+RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 500701
+RUN_DEPENDS+= ${SITE_PERL}/Encode.pm:${PORTSDIR}/devel/p5-Encode
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-DAV-Server/distinfo b/net/p5-Net-DAV-Server/distinfo
new file mode 100644
index 000000000000..a3633af0fc93
--- /dev/null
+++ b/net/p5-Net-DAV-Server/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DAV-Server-1.29.tar.gz) = a22ec5e46f1ad52c5cc67df7db9cbcfa
+SHA256 (Net-DAV-Server-1.29.tar.gz) = a5cd754a12f7590ab488a2f531767dff0d7307dc6213f083b26dea5df4c99f79
+SIZE (Net-DAV-Server-1.29.tar.gz) = 8123
diff --git a/net/p5-Net-DAV-Server/pkg-descr b/net/p5-Net-DAV-Server/pkg-descr
new file mode 100644
index 000000000000..9f1314dcfbcd
--- /dev/null
+++ b/net/p5-Net-DAV-Server/pkg-descr
@@ -0,0 +1,16 @@
+This module provides a WebDAV server. WebDAV stands for "Web-based
+Distributed Authoring and Versioning". It is a set of extensions to
+the HTTP protocol which allows users to collaboratively edit and
+manage files on remote web servers.
+
+Net::DAV::Server provides a WebDAV server and exports a filesystem for
+you using the Filesys::Virtual suite of modules. If you simply want to
+export a local filesystem, use Filesys::Virtual::Plain as above.
+
+This module doesn't currently provide a full WebDAV implementation.
+However, I am working through the WebDAV server protocol compliance
+test suite (litmus, see http://www.webdav.org/neon/litmus/) and will
+provide more compliance in future. The important thing is that it
+supports cadaver and the Mac OS X Finder as clients.
+
+WWW: http://search.cpan.org/dist/Net-DAV-Server/
diff --git a/net/p5-Net-DAV-Server/pkg-plist b/net/p5-Net-DAV-Server/pkg-plist
new file mode 100644
index 000000000000..128a76fff722
--- /dev/null
+++ b/net/p5-Net-DAV-Server/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DAV/Server/.packlist
+%%SITE_PERL%%/Net/DAV/Server.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DAV/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DAV
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/DAV
+@dirrmtry %%SITE_PERL%%/Net