aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Dropbox-API/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:20:16 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:20:16 +0000
commit21635e890fb32b3b37a3ab416be2c5f73be261d4 (patch)
tree0fd69d9501a8942cc140a301d4ae14523b346fb6 /net/p5-Net-Dropbox-API/Makefile
parentd0cf7356bf4e787a326f3a6a48fee95b2ce8dff6 (diff)
Notes
Diffstat (limited to 'net/p5-Net-Dropbox-API/Makefile')
-rw-r--r--net/p5-Net-Dropbox-API/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/p5-Net-Dropbox-API/Makefile b/net/p5-Net-Dropbox-API/Makefile
new file mode 100644
index 000000000000..95549d3c92ac
--- /dev/null
+++ b/net/p5-Net-Dropbox-API/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-Dropbox-API
+# Date created: 2010-11-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Dropbox-API
+PORTVERSION= 0.9
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A dropbox API interface
+
+RUN_DEPENDS= p5-Data-Random>=0:${PORTSDIR}/devel/p5-Data-Random \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-Net-OAuth>=0:${PORTSDIR}/net/p5-Net-OAuth \
+ p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Dropbox::API.3
+
+.include <bsd.port.mk>