aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-EPP/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-03 17:09:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-03 17:09:48 +0000
commit988ccba442fa200e2d1bc4cc5c840c8bfe7e166f (patch)
treeab10dbdab89083693b29beb7594328977924b1be /net/p5-Net-EPP/Makefile
parentd97869af054af0a42c33c254483a95ef1519b39a (diff)
Notes
Diffstat (limited to 'net/p5-Net-EPP/Makefile')
-rw-r--r--net/p5-Net-EPP/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/p5-Net-EPP/Makefile b/net/p5-Net-EPP/Makefile
index 7b85a556c875..eedd59b4b622 100644
--- a/net/p5-Net-EPP/Makefile
+++ b/net/p5-Net-EPP/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= Net-EPP
-PORTVERSION= 0.19
-PORTREVISION= 1
+PORTVERSION= 0.21
+DISTVERSIONSUFFIX= -1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,14 +11,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Client library for the TCP transport for EPP
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-Digest-SHA1>=2.12:${PORTSDIR}/security/p5-Digest-SHA1
-RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
- p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
- p5-Digest-SHA1>=2.12:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>