aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-FS-Gmail
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-21 15:21:50 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-21 15:21:50 +0000
commitc672ae15e89df20150ec32c51183530a1138b19f (patch)
treec1c093ad0d4522d7addd71be7b92718ce749744f /net/p5-Net-FS-Gmail
parent2cd3333f8f5823988790d8434888c6875168deae (diff)
downloadports-c672ae15e89df20150ec32c51183530a1138b19f.tar.gz
ports-c672ae15e89df20150ec32c51183530a1138b19f.zip
Notes
Diffstat (limited to 'net/p5-Net-FS-Gmail')
-rw-r--r--net/p5-Net-FS-Gmail/Makefile34
-rw-r--r--net/p5-Net-FS-Gmail/distinfo3
-rw-r--r--net/p5-Net-FS-Gmail/pkg-descr4
-rw-r--r--net/p5-Net-FS-Gmail/pkg-plist11
4 files changed, 52 insertions, 0 deletions
diff --git a/net/p5-Net-FS-Gmail/Makefile b/net/p5-Net-FS-Gmail/Makefile
new file mode 100644
index 000000000000..df9d170d0f1f
--- /dev/null
+++ b/net/p5-Net-FS-Gmail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net-FS-Gmail
+# Date created: 2006-07-20
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FS-Gmail
+PORTVERSION= 0.2
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= A Perl interface for store and retrieve files on Gmail
+
+BUILD_DEPENDS= ${SITE_PERL}/Mail/Webmail/Gmail.pm:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail \
+ ${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= gmailfs.1
+MAN3= Net::FS::Gmail.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-FS-Gmail/distinfo b/net/p5-Net-FS-Gmail/distinfo
new file mode 100644
index 000000000000..2da9ae390284
--- /dev/null
+++ b/net/p5-Net-FS-Gmail/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-FS-Gmail-0.2.tar.gz) = e07e6b7dc2b97c0a4229ade19901e6e6
+SHA256 (Net-FS-Gmail-0.2.tar.gz) = 7aafc705966139b1abe1a4c163d6affebdd41d16542a9de51294a8fa41fae977
+SIZE (Net-FS-Gmail-0.2.tar.gz) = 3944
diff --git a/net/p5-Net-FS-Gmail/pkg-descr b/net/p5-Net-FS-Gmail/pkg-descr
new file mode 100644
index 000000000000..3bb75bf52b4c
--- /dev/null
+++ b/net/p5-Net-FS-Gmail/pkg-descr
@@ -0,0 +1,4 @@
+This's a Perl interface for store and retrieve files on Gmail.
+
+Author: Simon Wistow <simon@thegestalt.org>
+WWW: http://search.cpan.org/dist/Net-FS-Gmail/
diff --git a/net/p5-Net-FS-Gmail/pkg-plist b/net/p5-Net-FS-Gmail/pkg-plist
new file mode 100644
index 000000000000..c42275e80b5a
--- /dev/null
+++ b/net/p5-Net-FS-Gmail/pkg-plist
@@ -0,0 +1,11 @@
+bin/gmailfs
+%%SITE_PERL%%/Net/FS/Gmail.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FS/Gmail/.packlist
+@dirrm share/nls/en_US.US-ASCII
+@dirrm share/nls/POSIX
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FS/Gmail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
+@dirrmtry %%SITE_PERL%%/Net/FS
+@dirrmtry %%SITE_PERL%%/Net