aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-FTP-File/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 17:45:25 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 17:45:25 +0000
commit42522c183f4c4d2b6428ace4081be3aa1465017d (patch)
tree28229aad87005e15d13536211ac4890d2359fe33 /net/p5-Net-FTP-File/Makefile
parent3cdf7f744813f54d898738e951bbbf63ef8bda6d (diff)
downloadports-42522c183f4c4d2b6428ace4081be3aa1465017d.tar.gz
ports-42522c183f4c4d2b6428ace4081be3aa1465017d.zip
Notes
Diffstat (limited to 'net/p5-Net-FTP-File/Makefile')
-rw-r--r--net/p5-Net-FTP-File/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/p5-Net-FTP-File/Makefile b/net/p5-Net-FTP-File/Makefile
new file mode 100644
index 000000000000..65e58ce04aeb
--- /dev/null
+++ b/net/p5-Net-FTP-File/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-FTP-File
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FTP-File
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension for simplifying FTP file operations
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Net::FTP::File.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6.0 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>