aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Google-SafeBrowsing2
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-06-24 18:36:18 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-06-24 18:36:18 +0000
commit97eba58c3ccf9c0c29f10e121f73b6208cd80e13 (patch)
treef3e2d8c6414a101d417fb4a5ef97a77eb623f636 /net/p5-Net-Google-SafeBrowsing2
parent521aeb9617f3abf2e615f4fae9ce5547d05c8612 (diff)
downloadports-97eba58c3ccf9c0c29f10e121f73b6208cd80e13.tar.gz
ports-97eba58c3ccf9c0c29f10e121f73b6208cd80e13.zip
Notes
Diffstat (limited to 'net/p5-Net-Google-SafeBrowsing2')
-rw-r--r--net/p5-Net-Google-SafeBrowsing2/Makefile64
-rw-r--r--net/p5-Net-Google-SafeBrowsing2/distinfo2
-rw-r--r--net/p5-Net-Google-SafeBrowsing2/pkg-descr20
-rw-r--r--net/p5-Net-Google-SafeBrowsing2/pkg-plist14
4 files changed, 100 insertions, 0 deletions
diff --git a/net/p5-Net-Google-SafeBrowsing2/Makefile b/net/p5-Net-Google-SafeBrowsing2/Makefile
new file mode 100644
index 000000000000..f812721d5845
--- /dev/null
+++ b/net/p5-Net-Google-SafeBrowsing2/Makefile
@@ -0,0 +1,64 @@
+# Created by: Alexandre Biancalana <ale@biancalanas.net>
+# $FreeBSD$
+
+PORTNAME= Net-Google-SafeBrowsing2
+PORTVERSION= 1.09
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ale@biancalanas.net
+COMMENT= Perl extension for the Google Safe Browsing v2 API
+
+BUILD_DEPENDS= p5-libwww>=5:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=1:${PORTSDIR}/net/p5-URI \
+ p5-Digest-SHA>=5:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-Net-IPAddress>=1:${PORTSDIR}/net-mgmt/p5-Net-IPAddress \
+ p5-Text-Trim>=1:${PORTSDIR}/textproc/p5-Text-Trim \
+ p5-MIME-Base64>=3:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-MIME-Base64-URLSafe>=0.01:${PORTSDIR}/converters/p5-MIME-Base64-URLSafe \
+ p5-Digest-HMAC>=1:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-String-HexConvert>=0.01:${PORTSDIR}/textproc/p5-String-HexConvert \
+ p5-File-Slurp>9:${PORTSDIR}/devel/p5-File-Slurp
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= MySQL SQLite Postgres
+
+MySQL_DESC= uses MySQL as the storage backend
+SQLite_DESC= uses SQLite as the storage backend
+Postgres_DESC= uses Postgres as the storage backend
+
+OPTIONS_DEFAULT=SQLite
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Google::SafeBrowsing2::Storage.3 \
+ Net::Google::SafeBrowsing2::Lookup.3 \
+ Net::Google::SafeBrowsing2::Postgres.3 \
+ Net::Google::SafeBrowsing2.3 \
+ Net::Google::SafeBrowsing2::DBI.3 \
+ Net::Google::SafeBrowsing2::MySQL.3 \
+ Net::Google::SafeBrowsing2::Sqlite.3
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSQLite}
+BUILD_DEPENDS+= p5-DBD-SQLite>=1:${PORTSDIR}/databases/p5-DBD-SQLite
+RUN_DEPENDS+= p5-DBD-SQLite>=1:${PORTSDIR}/databases/p5-DBD-SQLite
+.endif
+
+.if ${PORT_OPTIONS:MMySQL}
+BUILD_DEPENDS+= p5-DBD-mysql>=4:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= p5-DBD-mysql>=4:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+
+.if ${PORT_OPTIONS:MPostgres}
+BUILD_DEPENDS+= p5-DBD-Pg>=2:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= p5-DBD-Pg>=2:${PORTSDIR}/databases/p5-DBD-Pg
+.endif
+
+post-patch:
+ @${PERL} -pi -e 's/CPAN/ExtUtils/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-SafeBrowsing2/distinfo b/net/p5-Net-Google-SafeBrowsing2/distinfo
new file mode 100644
index 000000000000..3f9fa6bd2140
--- /dev/null
+++ b/net/p5-Net-Google-SafeBrowsing2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Google-SafeBrowsing2-1.09.tar.gz) = e9cd9b2c33c7e75054de1b567ad6e43f258f081614740ccec20c45cda9201507
+SIZE (Net-Google-SafeBrowsing2-1.09.tar.gz) = 28308
diff --git a/net/p5-Net-Google-SafeBrowsing2/pkg-descr b/net/p5-Net-Google-SafeBrowsing2/pkg-descr
new file mode 100644
index 000000000000..28703ff4e421
--- /dev/null
+++ b/net/p5-Net-Google-SafeBrowsing2/pkg-descr
@@ -0,0 +1,20 @@
+Net::Google::SafeBrowsing2 implements the Google Safe Browsing
+v2 API.
+
+The library passes most of the unit tests listed in the API
+documentation. See the documentation
+(http://code.google.com/apis/safebrowsing/developers_guide_v2.html)
+for more details about the failed tests.
+
+The Google Safe Browsing database must be stored and managed locally.
+Net::Google::SafeBrowsing2::Sqlite uses Sqlite as the storage back-end,
+Net::Google::SafeBrowsing2::MySQL uses MySQL. Other storage mechanisms
+(databases, memory, etc.) can be added and used transparently with this module.
+
+You may want to look at "Google Safe Browsing v2: Implementation Notes"
+(http://www.zscaler.com/research/Google%20Safe%20Browsing%20v2%20API.pdf),
+a collection of notes and real-world numbers about the API. This is intended
+for people who want to learn more about the API, whether as a user or to
+make their own implementation.
+
+WWW: http://search.cpan.org/dist/Net-Google-SafeBrowsing2/
diff --git a/net/p5-Net-Google-SafeBrowsing2/pkg-plist b/net/p5-Net-Google-SafeBrowsing2/pkg-plist
new file mode 100644
index 000000000000..7d15336431d4
--- /dev/null
+++ b/net/p5-Net-Google-SafeBrowsing2/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Net/Google/SafeBrowsing2.pm
+%%SITE_PERL%%/Net/Google/SafeBrowsing2/Storage.pm
+%%SITE_PERL%%/Net/Google/SafeBrowsing2/Lookup.pm
+%%SITE_PERL%%/Net/Google/SafeBrowsing2/Postgres.pm
+%%SITE_PERL%%/Net/Google/SafeBrowsing2/DBI.pm
+%%SITE_PERL%%/Net/Google/SafeBrowsing2/Sqlite.pm
+%%SITE_PERL%%/Net/Google/SafeBrowsing2/MySQL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/SafeBrowsing2/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/SafeBrowsing2
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Google/SafeBrowsing2
+@dirrmtry %%SITE_PERL%%/Net/Google
+@dirrmtry %%SITE_PERL%%/Net